Bug 10717 - crossbuild fails in modpost
crossbuild fails in modpost
Status: CLOSED INVALID
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: Sam Ravnborg
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-15 16:02 UTC by Rafael J. Wysocki
Modified: 2008-05-29 14:23 UTC (History)
2 users (show)

See Also:
Kernel Version: Commit 4ce6efed48d736e3384c39ff87bda723e1f8e041
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-15 16:02:30 UTC
Subject    : crossbuild fails in modpost
Submitter  : Jiri Slaby <jirislaby@gmail.com>
Date       : 2008-05-15 13:44
References : http://marc.info/?l=linux-kernel&m=121085909512097&w=4
Handled-By : Sam Ravnborg <sam@ravnborg.org>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-15 16:04:09 UTC
Probably caused by:

commit 4ce6efed48d736e3384c39ff87bda723e1f8e041
Author: Sam Ravnborg <sam@uranus.ravnborg.org>
Date:   Sun Mar 23 21:38:54 2008 +0100

    kbuild: soften modpost checks when doing cross builds

    Acked-by: Michael Buesch <mb@bu3sch.de>
    Tested-by: Gordon Farquharson <gordonfarquharson@gmail.com>
    Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
    Cc: stable@kernel.org
Comment 2 Jiri Slaby 2008-05-19 06:54:52 UTC
It turned out to be a real bug, which caused failing build. Fixed by
http://lkml.org/lkml/2008/5/19/203
and included also in hid patches in
http://lkml.org/lkml/2008/5/19/223

Sorry for the noise.
Comment 3 Rafael J. Wysocki 2008-05-20 15:00:31 UTC
Regressions list annotation:
Handled-By : Jiri Slaby <jirislaby@gmail.com>
Patch : http://lkml.org/lkml/2008/5/19/203
Not-Handled-By : Sam Ravnborg <sam@ravnborg.org>
Comment 4 Sam Ravnborg 2008-05-25 11:15:58 UTC
As per Jiri's comment this was not a regression.
Rejected. /Sam

Note You need to log in before you can comment on or make changes to this bug.