Bug 10710 - [BISECTED] Lots of "rescheduling IPIs" in powertop
[BISECTED] Lots of "rescheduling IPIs" in powertop
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-15 15:34 UTC by Rafael J. Wysocki
Modified: 2008-05-25 11:21 UTC (History)
4 users (show)

See Also:
Kernel Version: Commit 0c07ee38c9d4eb081758f5ad14bbffa7197e1aec
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-15 15:34:52 UTC
Subject    : [BISECTED] Lots of "rescheduling IPIs" in powertop
Submitter  : Vegard Nossum <vegard.nossum@gmail.com>
Date       : 2008-05-13 20:42
References : http://marc.info/?l=linux-kernel&m=121071176205864&w=4
Handled-By : Andi Kleen <andi@firstfloor.org>
Handled-By : Arjan van de Ven <arjan@infradead.org>
Handled-By : Ingo Molnar <mingo@elte.hu>
Patch      : http://marc.info/?l=linux-kernel&m=121074826823352&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-15 15:36:43 UTC
Caused by:

commit 0c07ee38c9d4eb081758f5ad14bbffa7197e1aec
Author: Andi Kleen <ak@suse.de>
Date:   Wed Jan 30 13:33:16 2008 +0100

    x86: use the correct cpuid method to detect MWAIT support for C states

    Cc: "Andreas Herrmann" <andreas.herrmann3@amd.com>
    Signed-off-by: Andi Kleen <ak@suse.de>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
    Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Comment 2 Andi Kleen 2008-05-15 17:30:29 UTC
I don't think that's correct in the regression list. It is currently
not clear it is even a regression. There's a fair chance it is actually
correct behavior on that box.
Comment 3 Rafael J. Wysocki 2008-05-20 15:26:26 UTC
Regressions list annotation:
References : http://lkml.org/lkml/2008/5/18/120
Comment 4 Adrian Bunk 2008-05-25 11:21:28 UTC
fixed by commit a738d897b7b03b83488ae74a9bc03d26a2875dc6

Note You need to log in before you can comment on or make changes to this bug.