Bug 10709 - 2.6.26-rc2 hosed X?
2.6.26-rc2 hosed X?
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-15 15:29 UTC by Rafael J. Wysocki
Modified: 2008-05-20 02:31 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-15 15:29:15 UTC
Subject    : 2.6.26-rc2 hosed X?
Submitter  : Norbert Preining <preining@logic.at>
Date       : 2008-05-13 10:38
References : http://marc.info/?l=linux-kernel&m=121067784803118&w=4
Handled-By : "Dave Airlie" <airlied@gmail.com>
Handled-By : Ingo Molnar <mingo@elte.hu>
Patch      : http://marc.info/?l=linux-kernel&m=121074889124387&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Norbert Preining 2008-05-15 22:57:13 UTC
In my email from above I mentioned that X behaves strangly and suspend/resume does not work. The latter seems to be solved with the patch from http://lkml.org/lkml/2008/5/13/188, the former with the patch as given above.
Comment 2 Norbert Preining 2008-05-19 07:09:19 UTC
I confirm that for proper operation I still need the drm-revert patch mentioned above under patch. Fortunately the other one mentioned in Comment #1 has been included.
Comment 3 Adrian Bunk 2008-05-20 02:31:16 UTC
fixed by commit af6061af0d9f84a4665f88186dc1ff9e4fb78330

Note You need to log in before you can comment on or make changes to this bug.