Bug 10679 - " pcspkr: fix dependancies" breaks artsd
Summary: " pcspkr: fix dependancies" breaks artsd
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Stas Sergeev
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-05-11 13:38 UTC by Rafael J. Wysocki
Modified: 2008-05-19 14:16 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-11 13:38:02 UTC
Subject    : 2.6.26-rc1 regression: e5e1d3cb20034a3cbcfff1f0bae12201aa2ce17e breaks artsd
Submitter  : Roberto Oppedisano <roberto.oppedisano@infracom.it>
Date       : 2008-05-11 20:15
References : http://lkml.org/lkml/2008/5/11/118
Handled-By : Stas Sergeev <stsp@aknet.ru>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-11 13:38:56 UTC
Probably caused by:

commit e5e1d3cb20034a3cbcfff1f0bae12201aa2ce17e
Author: Stas Sergeev <stsp@aknet.ru>
Date:   Wed May 7 12:39:56 2008 +0200

    pcspkr: fix dependancies

    fix pcspkr dependancies: make the pcspkr platform
    drivers to depend on a platform device, and
    not the other way around.

    Signed-off-by: Stas Sergeev <stsp@aknet.ru>
    Acked-by: Thomas Gleixner <tglx@linutronix.de>
    Acked-by: Dmitry Torokhov <dtor@mail.ru>
    CC: Vojtech Pavlik <vojtech@suse.cz>
    CC: Michael Opdenacker <michael-lists@free-electrons.com>
    [fixed for 2.6.26-rc1 by tiwai]
    Signed-off-by: Takashi Iwai <tiwai@suse.de>
Comment 2 Stas Sergeev 2008-05-12 11:34:00 UTC
This appeared to be not a kernel bug but
an unhappy combination of modprobe.conf
misconfiguration and alsa-lib problem.
But I expect other people may fall into
that, so I guess it would be good to keep
that bug open for some time, at least
till the alsa-lib 1.0.17 is released.

Solution is here:
http://lkml.org/lkml/2008/5/11/172
Comment 3 Rafael J. Wysocki 2008-05-13 12:58:42 UTC
Not a regression.

References : http://lkml.org/lkml/2008/5/13/119

Dropping from the list of recent regressions.
Comment 4 Rafael J. Wysocki 2008-05-16 13:09:13 UTC
Adding to the regressions list again.
References : http://bugzilla.kernel.org/show_bug.cgi?id=10701
Comment 5 Rafael J. Wysocki 2008-05-16 13:09:41 UTC
*** Bug 10701 has been marked as a duplicate of this bug. ***
Comment 6 Rafael J. Wysocki 2008-05-16 13:11:18 UTC
Regressions list annotation:
Patch : http://marc.info/?l=linux-kernel&m=121096158624210&w=4
Comment 7 Adrian Bunk 2008-05-19 14:16:55 UTC
fixed by commit 4dfd79546dfed83bf756f5c912f686ebac187c16

Note You need to log in before you can comment on or make changes to this bug.