Bug 10675 - ppc compile failure (__flush_icache_range etc undeclared)
ppc compile failure (__flush_icache_range etc undeclared)
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
All Linux
: P1 normal
Assigned To: platform_ppc-32
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-11 13:20 UTC by Rafael J. Wysocki
Modified: 2008-05-14 14:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc1-git
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-11 13:20:13 UTC
Subject    : ppc compile failure (__flush_icache_range etc undeclared)
Submitter  : Meelis Roos <mroos@linux.ee>
Date       : 2008-05-10 11:51
References : http://marc.info/?l=linux-kernel&m=121042037427529&w=4
Handled-By : Josh Boyer <jwboyer@linux.vnet.ibm.com>
Handled-By : Segher Boessenkool <segher@kernel.crashing.org>
Patch      : http://ozlabs.org/pipermail/linuxppc-dev/2008-May/056007.html
Patch      : http://ozlabs.org/pipermail/linuxppc-dev/2008-May/056008.html

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Josh Boyer 2008-05-11 14:00:55 UTC
This should be PPC-32, not SPARC32
Comment 2 Rafael J. Wysocki 2008-05-11 14:03:30 UTC
Ah, my fault.  Thanks!
Comment 3 Josh Boyer 2008-05-11 14:13:09 UTC
No problem.  I'll try to bug Paul about taking the patches that fix the issues.
Comment 4 Adrian Bunk 2008-05-14 14:38:11 UTC
fixed by commits 9717e87fb19f21d1be2ac1dce8f65045547b7e1b and 6a8b23086c82d7cc4f424518532c8b10d95715c0

Note You need to log in before you can comment on or make changes to this bug.