Bug 1067 - USB printer is not seen anymore
USB printer is not seen anymore
Status: REJECTED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Randy Dunlap
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2003-08-09 15:00 UTC by Xavier
Modified: 2005-08-18 16:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6-test3 (and 2.5.75)
Tree: Mainline
Regression: ---


Attachments
Output of lspci -v (3.70 KB, text/plain)
2003-08-09 15:01 UTC, Xavier
Details
Output of cat /proc/bus/usb/devices with 2.4.20 (1.26 KB, text/plain)
2003-08-09 15:02 UTC, Xavier
Details
Output of cat /proc/bus/usb/devices with 2.6.0-test3 (1.08 KB, text/plain)
2003-08-09 15:02 UTC, Xavier
Details
Output of dmesg with 2.4.20 (14.95 KB, text/plain)
2003-08-09 15:03 UTC, Xavier
Details
Output of dmesg with 2.6.0-test3 (15.00 KB, text/plain)
2003-08-09 15:03 UTC, Xavier
Details
.config files used to compile 2.6.0-test3 (19.54 KB, text/plain)
2003-08-09 15:04 UTC, Xavier
Details

Description Xavier 2003-08-09 15:00:19 UTC
Distribution:Gentoo 1.4
Hardware Environment:Dual P3-733, 512Kb, hda, hde/hdf on PDC..65.., SCSI DVD and
CDRW on AIC7xxx

Problem Description:Dymo label printer is not recognized anymore and
/dev/usb/lp0 is not available. It does work with 2.4.20. Did not work with 2.5.75.

Steps to reproduce:boot with 2.6 instead of 2.4.20
Comment 1 Xavier 2003-08-09 15:01:10 UTC
Created attachment 628 [details]
Output of lspci -v
Comment 2 Xavier 2003-08-09 15:02:30 UTC
Created attachment 629 [details]
Output of cat /proc/bus/usb/devices with 2.4.20
Comment 3 Xavier 2003-08-09 15:02:58 UTC
Created attachment 630 [details]
Output of cat /proc/bus/usb/devices with 2.6.0-test3
Comment 4 Xavier 2003-08-09 15:03:29 UTC
Created attachment 631 [details]
Output of dmesg with 2.4.20
Comment 5 Xavier 2003-08-09 15:03:52 UTC
Created attachment 632 [details]
Output of dmesg with 2.6.0-test3
Comment 6 Xavier 2003-08-09 15:04:21 UTC
Created attachment 633 [details]
.config files used to compile 2.6.0-test3
Comment 7 Greg Kroah-Hartman 2003-08-14 09:34:30 UTC
What are the kernel log messages that occur when you plug your printer in?

If you plug it in after booting, does that help?
Comment 8 Xavier 2003-08-14 11:56:24 UTC
It does not matter whether I plug the printer before or after I boot the machine.
I booted the machine with the label printer unplugged and later on plugged it in.
The following lines appear in the /proc/bus/usb/devices

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 0.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 0 #Cfgs=  0
P:  Vendor=0000 ProdID=0000 Rev= 0.00

and here are the lines appended to dmesg

hub 1-0:0: port 1, status 101, change 1, 12 Mb/s
hub 1-0:0: debounce: port 1: delay 100ms stable 4 status 0x101
hub 1-0:0: new USB device on port 1, assigned address 2
drivers/usb/core/message.c: usb_control/bulk_msg: timeout

Comment 9 Randy Dunlap 2003-08-18 10:08:06 UTC
Is the working 2.4.20 version done with a plain, unchanged 2.4.20,
or is it patched?
Comment 10 Xavier 2003-08-18 10:31:42 UTC
The working install uses a plain vanilla 2.4.20

Linux polly.a.la.maison 2.4.20 #3 SMP Sat Aug 9 22:55:23 CEST 2003 i686 Pentium
III (Coppermine) GenuineIntel GNU/Linux
Comment 11 Diego Calleja 2004-08-13 17:18:34 UTC
Sorry, but haven't been the USB printer support moved to userspace via libusb in
current 2.6 kernels?
Comment 12 Randy Dunlap 2004-08-13 22:22:19 UTC
usblp kernel driver is still used for usb printers.  not libusb.
Comment 13 Nishanth Aravamudan 2005-02-17 11:57:02 UTC
Xavier, could you test with 2.6.11-rc4? Does the problem still occur? Thanks, Nish
Comment 14 MoS 2005-03-25 13:35:12 UTC
I recently spent several days trying to detect my UPS, an MGE Ellipse USB.
I found a page (http://linuxfr.org/2003/08/25/13729.html), where a guy said 
that my problem with the HID module was similar to this one, even if it 
concerns printers.
So that's why I answer to Nishanth, hoping it might help.
I tried 2.6.11-rc4, as requested by Nishanth, but it still doesn't work
For the moment, the only working kernel for me is still kernel 2.4.20 with 
USB_TIMEOUT option.
Comment 15 Nishanth Aravamudan 2005-03-28 10:56:24 UTC
One option, I think, may be to increase
USB_CTRL_SET_TIMEOUT/USB_CTRL_GET_TIMEOUT directly in the code. This is
mentioned in the comment in usb.h:

 * timeouts, in milliseconds, used for sending/receiving control messages
 * they typically complete within a few frames (msec) after they're issued
 * USB identifies 5 second timeouts, maybe more in a few cases, and a few
 * slow devices (like some MGE Ellipse UPSes) actually push that limit.

When the Ellipse UPS was mentioned and I saw the comment, I thought maybe there
might be connection. And the fact that you are seeing timeouts. I am not sure
what a more reasonable value would be, though. Maybe 10000, that would be 10
seconds, which I think should be more than long enough.
Comment 16 MoS 2005-06-06 00:09:39 UTC
Thanks for the advice Nishanth, and sorry for the delay (holidays...).
I will modify the given options in the code and re-try with several kernels as 
soon as possible, and report here if it works.
Comment 17 Nishanth Aravamudan 2005-07-16 23:02:10 UTC
Any update on trying to increase the timeout value?

Thanks,
Nish
Comment 18 Greg Kroah-Hartman 2005-08-18 16:15:50 UTC
Closing this bug due to long delay from last report.

If this still shows up on 2.6.13-rc6 or greator, please reopen this.

Note You need to log in before you can comment on or make changes to this bug.