Bug 10667 - Enable NVidia MSI-HT quirk for ALi bridges as well
Summary: Enable NVidia MSI-HT quirk for ALi bridges as well
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_pci@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-11 09:54 UTC by Björn Krombholz
Modified: 2008-05-12 16:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25.3
Tree: Mainline
Regression: Yes


Attachments
lspci -vvvnn on vanilla 2.6.25.3 (25.59 KB, text/plain)
2008-05-11 09:55 UTC, Björn Krombholz
Details
lspci -vvvnn on ALi quirk enabled 2.6.25.3 (25.59 KB, text/plain)
2008-05-11 09:56 UTC, Björn Krombholz
Details
patch to enable MSI on HT cap quirk for ALi devices (416 bytes, patch)
2008-05-11 09:59 UTC, Björn Krombholz
Details | Diff

Description Björn Krombholz 2008-05-11 09:54:17 UTC
Latest working kernel version: 2.6.23
Earliest failing kernel version: 2.6.24
Distribution: Debian/Sid
Hardware Environment: AMD64, Board: ASRock ALiveDual-eSATA2 (nForce3 250Gb with ALi M1695 Northbridge), RTL8111/8168B via PCI Express
Software Environment: 

Problem Description:
I found this problem because my internal RTL8111b network chip hasn't been working anymore since 2.6.24. Then I found the bug report: http://bugzilla.kernel.org/show_bug.cgi?id=10301 which exactly described my problem as well, but was solved with commit 9dc625e72309e1c919ea3e7f51d0ffca96123787 since ~2.6.25rc3.

Unfortunately the problem persists for my setup. All reports about this issue on various distribution bug trackers that were resolved by this commit indicated that the reporters were running "pure" nVidia chipsets. My NIC is connected through the PCI Express bus on an ALi Northbridge though, and according to lspci  the MSI Mapping flag wasn't set as well.

So I tried enabling the quirk for ALi devices as well and it works fine.

The lspvi -vvvnn outputs of the patched and unpatched kernels + the tiny patch are attached.

Steps to reproduce:
Just run a vanilla 2.6.24/25 on the board specified above (with MSI enabled).


PS: Marking as regression and high as it breaks the NIC on the device and worked in 2.6.23 where MSI doesn't seem to be enabled by default.

PPS: The other bug 10301 mentioned above is probably assigned to the wrong person and could be closed IMHO.
Comment 1 Björn Krombholz 2008-05-11 09:55:44 UTC
Created attachment 16099 [details]
lspci -vvvnn on vanilla 2.6.25.3
Comment 2 Björn Krombholz 2008-05-11 09:56:43 UTC
Created attachment 16100 [details]
lspci -vvvnn on ALi quirk enabled 2.6.25.3
Comment 3 Björn Krombholz 2008-05-11 09:59:08 UTC
Created attachment 16101 [details]
patch to enable MSI on HT cap quirk for ALi devices
Comment 4 Andrew Morton 2008-05-11 11:24:58 UTC
We much prefer that patches be handled by email, please.

Can you send it to

linux-kernel@vger.kernel.org
linux-pci@vger.kernel.org
Jesse Barnes <jbarnes@virtuousgeek.org>
Andrew Morton <akpm@linux-foundation.org>

As described in Documentation/SubmittingPatches?

Thanks.
Comment 5 Björn Krombholz 2008-05-11 16:36:20 UTC
Done.

OT: Although the SMTP server of Jesse Barnes returned an "5.6.1 Body type not supported by Remote Host". I've no idea how to solve this. I explicitly set the UTF-8 encoding for the mail as requested in the docs.
Comment 6 Andrew Morton 2008-05-12 16:56:33 UTC
Yeah, I've basically given up on trying to get the utf stuff to
work right - it just causes too many problems.

So I anglicised your name in the patch, sorry.

Note You need to log in before you can comment on or make changes to this bug.