Bug 106651 - Problem with SHIFT, ALT and CTRL buttons of keyboard
Summary: Problem with SHIFT, ALT and CTRL buttons of keyboard
Status: NEW
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: other_other
URL:
Keywords: trivial
: 106641 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-26 21:38 UTC by andrea.deangelis93
Modified: 2015-12-02 08:38 UTC (History)
1 user (show)

See Also:
Kernel Version: All
Tree: Mainline
Regression: No


Attachments

Description andrea.deangelis93 2015-10-26 21:38:05 UTC
I've bought a new notebook.
HP Pavilion 15 ab062nl.
but i've a problem with keyboard with SHIFT, ALT and CTRL buttons.
for example, when i press SHIFT button to write Upper case letters, writes some letters upper case, and then starts to write letters lowercase, even if i'm still pressing SHIFT button.
it is like if i release the button, but isn't so.

i've the same problem with ALT (for example when i use ALT-TAB), and the same problem with CTRL buttons.+

the problem is that it is as if I left these buttons, but it isn't.

Sometimes it is as if these buttons are pressed autonomously, for example when i scroll pages on firefox (or other browser) using wheel of mouse, sometimes it is like if i press ALT button, and firefox starts to resize the zoom of the page, but i'm not pressing ALT button.

furthermore I discovered that if i press the only SHIFT buttons for 1 or 2 seconds, all these problmems momentarily disappear (until i rebook system).

i've noticed this bug with all distro (i've tested ArchLinux, Antergos, Fedora 16 and Fedora 23, Ubuntu 15.10 Ubuntu 14.04, Debian 8.0.2).
i've tested only x86_64 distros, and i've tested with all DE (and also without a DE).

this isn't an hardware problem, because on Windows i haven't these problems, and even on a linux distro on virtualbox under windows.

	
i don't know which is the cause of this problem.

My hardware:
CPU: AMD A10 8700p
GPU: radeon r6 + radeon r7 m360
RAM: 8GB DDR3L 1600mhz

if i try with an external USB keyboard, i haven't these problems
Comment 1 andrea.deangelis93 2015-11-04 21:08:15 UTC
*** Bug 106641 has been marked as a duplicate of this bug. ***
Comment 2 andrea.deangelis93 2015-11-04 21:16:06 UTC
i've also tried with 32bit distributions, but i've the same problems.
and i've also tried with fedora 23, on gnome wayland session.

this is a very boring bug, i don't know wich is the cause.
Comment 3 andrea.deangelis93 2015-12-02 08:38:50 UTC
this is "dmesg | grep input" output http://pastebin.com/Nn4wBhjh

this is "journalctl -b |grep input" output http://pastebin.com/HRr2mKBU

this is "xinput" output http://pastebin.com/gF6AR1pR

this is "lsmod" output http://pastebin.com/NkvuuRhB

this is the content of file config of keyboard "cat /etc/X11/xorg.conf.d/00-keyboard.conf" http://pastebin.com/751TDUHs

Note You need to log in before you can comment on or make changes to this bug.