Bug 10665 - kernel crash on Realtek RTL8101E ethernet controller
Summary: kernel crash on Realtek RTL8101E ethernet controller
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Francois Romieu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-10 15:56 UTC by Hadmut Danisch
Modified: 2008-06-09 14:08 UTC (History)
0 users

See Also:
Kernel Version: 2.6.24-16 (ubuntu 8.04)
Tree: Mainline
Regression: ---


Attachments
dmesg output (7.66 KB, text/plain)
2008-05-10 15:58 UTC, Hadmut Danisch
Details
lspci output (14.60 KB, application/octet-stream)
2008-05-10 15:58 UTC, Hadmut Danisch
Details

Description Hadmut Danisch 2008-05-10 15:56:19 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution: Ubuntu 8.04
Hardware Environment: Thoshiba Satellite Notebook
Software Environment: Ubuntu alternate i386 installation 
Problem Description:

Hi, 

I just tried to install Ubuntu 8.04 with the i386 alternate CD on a brand new Toshiba Satellite Notebook. Installation reproducibly fails due to a kernel crash at the moment when the r8169 driver is inserted. I'll attach dmesg and lspci output. 

regards




Steps to reproduce:
Comment 1 Hadmut Danisch 2008-05-10 15:58:18 UTC
Created attachment 16095 [details]
dmesg output

Dmesg output after the Ubuntu installation script inserted the r8169 driver.
Comment 2 Hadmut Danisch 2008-05-10 15:58:41 UTC
Created attachment 16096 [details]
lspci output
Comment 3 Francois Romieu 2008-05-11 02:26:24 UTC
The bug was added by commit e3cf0cc09141ddef9d75a984c0d286040f1f2743 and
fixed by 21e197f231343201368338603cb0909a13961bac. As it is a recent
chipset, cee60c377de6d9d10f0a2876794149bd79a15020 could make a difference
too.

As a consequence you can either use a kernel strictly older than
2.6.24-rc1 or more recent then 2.6.25. 2.6.26-rc1 should not crash at
the same place for instance.

I have just submitted both changes to 2.6.24-stable and 2.6.25-stable.

-- 
Ueimor

-- 
Ueimor
Comment 4 Hadmut Danisch 2008-05-11 07:15:43 UTC
Well, I tried to use 2.6.22 (Ubuntu 7.10). 

While it smoothly starts up without any error message and presents an eth0 device that can be configured, it still does not work in the way that it does not send or receives any packages. tcpdump shows only it's own traffic. 

Meanwhile I found a workaround, i.e. I've removed the r8169 driver from the 2.6.22 kernel package and installed Realtek's Linux driver for 8101 from
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false

It works, but unfortunately does not compile with 2.6.24. So I am currently bound to use the 2.6.22 kernel (or to try a 2.6.26). 

regards
Comment 5 Francois Romieu 2008-05-30 10:44:17 UTC
The bug is fixed in 2.6.25.4 and v2.6.26-rc1.

Can you try any of those and report if 
1. it does not crash
2. it works better

If it does not work, please send a complete dmesg and a lspci -vx.

Thanks in advance

-- 
Ueimor
Comment 6 Francois Romieu 2008-06-09 14:08:13 UTC
The crashing part has been reported to work. See https://bugs.launchpad.net/bugs/229113 for instance.

-- 
Ueimor

Note You need to log in before you can comment on or make changes to this bug.