Bug 10661 - PCMCIA: CompactFlash card can't be mounted.
PCMCIA: CompactFlash card can't be mounted.
Status: RESOLVED DUPLICATE of bug 10957
Product: Drivers
Classification: Unclassified
Component: PCMCIA
All Linux
: P1 normal
Assigned To: linux-pcmcia
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 02:41 UTC by Kseniya
Modified: 2008-09-22 08:04 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25.3
Tree: Mainline
Regression: Yes


Attachments

Description Kseniya 2008-05-10 02:41:24 UTC
Latest working kernel version: 2.6.24
Earliest failing kernel version:
Distribution:
Hardware Environment: IBM t-43, PCMCIA card-reader Transcend CompactFlash Adapter, CF-card Kingston ElitePro.
Software Environment:
Problem Description:
I cannot mount my CF-card via PCMCIA card-reader.
dmesg:
[  657.489156] pccard: PCMCIA card inserted into slot 0
[  657.489683] pcmcia: registering new device pcmcia0.0
[  657.533449] scsi4 : pata_pcmcia
[  657.533501] ata5: PATA max PIO0 cmd 0x4100 ctl 0x410e irq 5
[  657.682481] ata5.00: CFA: ELITE PRO CF CARD 1GB, 20070131, max MWDMA4
[  657.682489] ata5.00: 1989792 sectors, multi 0: LBA 
[  657.685331] ata5.00: configured for PIO0
[  657.691049] ata5.00: configured for PIO0
[  657.691054] ata5: EH complete
[  657.691569] scsi 4:0:0:0: Direct-Access     ATA      ELITE PRO CF CAR 2007 PQ
: 0 ANSI: 5
[  657.692149] sd 4:0:0:0: [sdb] 1989792 512-byte hardware sectors (1019 MB)
[  657.692304] sd 4:0:0:0: [sdb] Write Protect is off
[  657.692309] sd 4:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[  657.692544] sd 4:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doe
sn't support DPO or FUA
[  657.692909] sd 4:0:0:0: [sdb] 1989792 512-byte hardware sectors (1019 MB)
[  657.693045] sd 4:0:0:0: [sdb] Write Protect is off
[  657.693050] sd 4:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[  657.693273] sd 4:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doe
sn't support DPO or FUA
[  657.693278]  sdb: sdb1
[  657.714070] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[  657.714113] sd 4:0:0:0: Attached scsi generic sg2 type 0
[  657.714141] pcmcia: registering new device pcmcia0.1
[  657.714357] 0.1: GetNextTuple: No more items
[  657.714376] pata_pcmcia: probe of 0.1 failed with error -12
[  657.714403] 0.1: GetNextTuple: No more items
[  657.719290] 0.1: GetNextTuple: No more items
[  657.719305] pata_pcmcia: probe of 0.1 failed with error -12
[  657.719324] 0.1: GetNextTuple: No more items
[  657.722048] 0.1: GetNextTuple: No more items
[  657.722060] pata_pcmcia: probe of 0.1 failed with error -12
[  657.722079] 0.1: GetNextTuple: No more items
--------------------------------
less /etc/fstab | grep sdb
/dev/sdb1       /mnt/flash      auto    user,noauto     0       0
-------------------------------------
~$ mount /mnt/flash
mount: I could not determine the filesystem type, and none was specified
--------------------------
~$ sudo mount /mnt/flash /dev/sdb1 -t vfat
mount: mount point /dev/sdb1 does not exist
-------------------------------------

Steps to reproduce:
Comment 1 Andrew Morton 2008-05-10 11:11:58 UTC
argh, I know nothing about pcmcia card services and Dominik
seems to have disappeared.

At a guess, I'd say that some misbehaviour in pata_pcmcia
has caused the pcmcia core to get this CS_NO_MORE_ITEMS
status.  But we changed little in pata_pcmcia and in
pcmcia for 2.6.25.

Hopefully Alan or Russell can suggest what might cause this?
Comment 2 Kristoffer Ericson 2008-05-10 11:33:33 UTC
Without taking any notice of the pata_pcmcia: probe of 0.1 failed with error -12 
but that mount command doesn't look right, shouldn't device be at left of mountpoint.
Comment 3 Alan 2008-05-10 14:01:20 UTC
No idea, no similar reports I've seen and also we use the same pcmcia side code as ide_cs which has worked for years.
Comment 4 Kseniya 2008-06-01 11:10:14 UTC
On Sat, May 10, 2008 at 11:33:34AM -0700, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10661
> 
> 
> 
> 
> 
> ------- Comment #2 from kristoffer.ericson@gmail.com  2008-05-10 11:33 -------
> Without taking any notice of the pata_pcmcia: probe of 0.1 failed with error
> -12 
> but that mount command doesn't look right, shouldn't device be at left of
> mountpoint.

The same result:

~$ sudo mount -t vfat /dev/sdb1 /mnt/flash
mount: special device /dev/sdb1 does not exist

Comment 5 Alan 2008-09-22 08:04:12 UTC

*** This bug has been marked as a duplicate of bug 10957 ***

Note You need to log in before you can comment on or make changes to this bug.