Bug 10639 - parisc DISCONTIGMEM compile breakage
parisc DISCONTIGMEM compile breakage
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PA-RISC
All Linux
: P1 normal
Assigned To: Matthew Wilcox
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 13:52 UTC by Adrian Bunk
Modified: 2008-05-14 13:42 UTC (History)
0 users

See Also:
Kernel Version: 2.6.26-rc1-git
Tree: Mainline
Regression: Yes


Attachments

Description Adrian Bunk 2008-05-08 13:52:46 UTC
Subject         : parisc DISCONTIGMEM compile breakage
Submitter       : Adrian Bunk <bunk@kernel.org>
References      : http://kerneltrap.org/mailarchive/linux-kernel/2008/5/6/1740534
Handled-By      : Mel Gorman <mel@csn.ul.ie>
Patch           : http://kerneltrap.org/mailarchive/linux-kernel/2008/5/6/1741324
Comment 1 Adrian Bunk 2008-05-08 13:53:34 UTC
Caused by:

commit 54a6eb5c4765aa573a030ceeba2c14e3d2ea5706
Author: Mel Gorman <mel@csn.ul.ie>
Date:   Mon Apr 28 02:12:16 2008 -0700

    mm: use two zonelist that are filtered by GFP mask
    
    Currently a node has two sets of zonelists, one for each zone type in the
    system and a second set for GFP_THISNODE allocations.  Based on the zones
    allowed by a gfp mask, one of these zonelists is selected.  All of these
    zonelists consume memory and occupy cache lines.
    
    This patch replaces the multiple zonelists per-node with two zonelists.  The
    first contains all populated zones in the system, ordered by distance, for
    fallback allocations when the target/preferred node has no free pages.  The
    second contains all populated zones in the node suitable for GFP_THISNODE
    allocations.
    
    An iterator macro is introduced called for_each_zone_zonelist() that interat
    through each zone allowed by the GFP flags in the selected zonelist.
    
    Signed-off-by: Mel Gorman <mel@csn.ul.ie>
    Acked-by: Christoph Lameter <clameter@sgi.com>
    Signed-off-by: Lee Schermerhorn <lee.schermerhorn@hp.com>
    Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
    Cc: Mel Gorman <mel@csn.ul.ie>
    Cc: Christoph Lameter <clameter@sgi.com>
    Cc: Hugh Dickins <hugh@veritas.com>
    Cc: Nick Piggin <nickpiggin@yahoo.com.au>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 2 Adrian Bunk 2008-05-14 13:42:47 UTC
fixed by commit 4413a0f637df4e59b934909ac388a21cfdd90e69

Note You need to log in before you can comment on or make changes to this bug.