Bug 10638 - sysbench+mysql(oltp, readonly) 30% regression with 2.6.26-rc1
sysbench+mysql(oltp, readonly) 30% regression with 2.6.26-rc1
Status: CLOSED CODE_FIX
Product: Process Management
Classification: Unclassified
Component: Scheduler
All Linux
: P1 normal
Assigned To: Ingo Molnar
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 13:51 UTC by Rafael J. Wysocki
Modified: 2008-06-05 14:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-08 13:51:37 UTC
Subject    : sysbench+mysql(oltp, readonly) 30% regression with 2.6.26-rc1
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2008-05-07 4:55
References : http://marc.info/?l=linux-kernel&m=121013681527052&w=2
Handled-By : Ingo Molnar <mingo@elte.hu>
Patch      : http://marc.info/?l=linux-kernel&m=121015292616802&w=2

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-08 13:52:44 UTC
Caused by:

commit 8f1bc385cfbab474db6c27b5af1e439614f3025c
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Sat Apr 19 19:45:00 2008 +0200

    sched: fair: weight calculations

    Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
Comment 2 Rafael J. Wysocki 2008-05-20 15:10:24 UTC
Regressions list annotation:
Handled-By : Peter Zijlstra <peterz@infradead.org>
References : http://lkml.org/lkml/2008/5/18/177
Comment 3 Rafael J. Wysocki 2008-06-05 14:36:11 UTC
Confirmed to be fixed in the Linus' tree.
References : http://lkml.org/lkml/2008/6/2/10

Note You need to log in before you can comment on or make changes to this bug.