Bug 10633 - Problem mounting ext2 using ext3 (or any failure to mount a partition) leads to an oops.
Problem mounting ext2 using ext3 (or any failure to mount a partition) leads ...
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: ext3
All Linux
: P1 normal
Assigned To: Theodore Tso
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 13:19 UTC by Rafael J. Wysocki
Modified: 2008-05-14 05:39 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.25-git-f74d505b58d36ceeef10e459094f0eb760681165
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-08 13:19:57 UTC
Subject    : Problem mounting ext2 using ext3?
Submitter  : Geert Uytterhoeven <geert@linux-m68k.org>
Date       : 2008-05-05 17:12
References : http://www.ussg.iu.edu/hypermail/linux/kernel/0805.0/2281.html
Handled-By : Theodore Tso <tytso@mit.edu>
Handled-By : Jan Kara <jack@suse.cz>
Patch      : http://marc.info/?l=linux-kernel&m=121006820018050&w=2

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Theodore Tso 2008-05-08 19:35:16 UTC
It's technically a bug with the quota subsystem, and it will affect any failed mount where the filesystem-specific get_sb() function returns an error.  So for example, I suspect that an explicit "mount -t xfs /dev/mapper/my_ext3_filesstem" will also result in the same oops, because xfs's get_sb() function will return a failure, and then when fs/super.c calls deactivate_super(), which calls DQUOT_OFF(), the same failure will happen.
Comment 2 Soeren Sonnenburg 2008-05-11 21:42:17 UTC
I am also affected by this, trying the patch now.
Comment 3 Soeren Sonnenburg 2008-05-11 22:18:25 UTC
the patch also fixes things for me.
Comment 4 Jan Kara 2008-05-14 04:49:05 UTC
Linus has merged the fix so we can close the bug (hmm, I don't seem to be able to do this - Theodore, can you do that? Thanks).
Comment 5 Rafael J. Wysocki 2008-05-14 05:27:26 UTC
Closing, but can you please provide the fixing commit hash?
Comment 6 Jan Kara 2008-05-14 05:39:47 UTC
The commit id is 9377abd026bf9bde7db90dac09170034bf6d1cbf

Note You need to log in before you can comment on or make changes to this bug.