Bug 10630 - USB devices plugged into dock are not discoverred until reload of ehci-hcd
USB devices plugged into dock are not discoverred until reload of ehci-hcd
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Alan Stern
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 12:55 UTC by Rafael J. Wysocki
Modified: 2008-05-31 11:29 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments
dmesg output (122.54 KB, text/plain)
2008-05-09 02:19 UTC, Lukas Hejtmanek
Details
clean dmesg (72.94 KB, application/octet-stream)
2008-05-12 04:02 UTC, Lukas Hejtmanek
Details
Dmesg output (57.43 KB, text/plain)
2008-05-19 01:48 UTC, Lukas Hejtmanek
Details
dmesg from working 2.6.25 kernel (56.83 KB, text/plain)
2008-05-20 01:31 UTC, Lukas Hejtmanek
Details
dmesg from 2.6.26 without ehci module (61.39 KB, application/octet-stream)
2008-05-20 01:32 UTC, Lukas Hejtmanek
Details
My config file (46.44 KB, text/plain)
2008-05-20 04:16 UTC, Lukas Hejtmanek
Details

Description Rafael J. Wysocki 2008-05-08 12:55:59 UTC
Subject    : 2.6.26-rc1 regression since 2.6.25
Submitter  : Lukas Hejtmanek <xhejtman@ics.muni.cz>
Date       : 2008-05-05 10:02
References : http://lkml.org/lkml/2008/5/5/77

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Lukas Hejtmanek 2008-05-09 02:19:21 UTC
Created attachment 16078 [details]
dmesg output

in the attached dmesg, it can be seen that device is discovered after USB HW is disabled and enabled again. The device has been plugged before and I took some time to settle the device down but it still was not discovered.
Comment 2 Greg Kroah-Hartman 2008-05-09 08:18:46 UTC
You are suspending and resuming a lot.

can you just provide a clean log file, without any suspend/resume?

Just boot the box, then plug it in.
Comment 3 Lukas Hejtmanek 2008-05-12 04:02:15 UTC
Created attachment 16110 [details]
clean dmesg

Clean dmesg output. In time about 106.xx I've removed ehci_hcd and after that the usb device has been detected.
Comment 4 Lukas Hejtmanek 2008-05-19 01:48:07 UTC
Created attachment 16191 [details]
Dmesg output

Dmesg with greg usb patch.
Comment 5 Lukas Hejtmanek 2008-05-20 01:31:21 UTC
Created attachment 16211 [details]
dmesg from working 2.6.25 kernel

This is dmesg from vanila 2.6.25 kernel. The plugged device is discovered.
Comment 6 Lukas Hejtmanek 2008-05-20 01:32:14 UTC
Created attachment 16212 [details]
dmesg from 2.6.26 without ehci module

This is dmesg from 2.6.26 kernel without an ehci module. uhci module discovers the device.
Comment 7 Lukas Hejtmanek 2008-05-20 04:16:25 UTC
Created attachment 16214 [details]
My config file

My config file
Comment 8 Rafael J. Wysocki 2008-05-20 15:24:22 UTC
Regressions list annotation:
References : http://lkml.org/lkml/2008/5/19/44
Handled-By : Oliver Neukum <oliver@neukum.org>
Handled-By : Alan Stern <stern@rowland.harvard.edu>
Patch : http://lkml.org/lkml/2008/5/20/285
Comment 9 Rafael J. Wysocki 2008-05-31 11:29:53 UTC
Fixed by commit d1f114d12bb4db3147e1b1342ae31083c5a79c84.

Note You need to log in before you can comment on or make changes to this bug.