Bug 10624 - DVB build issue
DVB build issue
Status: CLOSED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: dvb-core
All Linux
: P1 normal
Assigned To: dvb-core
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 12:14 UTC by Rafael J. Wysocki
Modified: 2008-05-15 08:45 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments
Fixes I2C=n build bug (543 bytes, patch)
2008-05-12 09:08 UTC, Alistair Strachan
Details | Diff

Description Rafael J. Wysocki 2008-05-08 12:14:13 UTC
Subject    : DVB build issue
Submitter  : Alistair John Strachan <alistair@devzero.co.uk>
Date       : 2008-05-03 22:47
References : http://lkml.org/lkml/2008/5/3/247
Handled-By : Mauro Carvalho Chehab <mchehab@infradead.org>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 2 Alistair Strachan 2008-05-08 17:19:54 UTC
This is not the correct fix for the bug I reported. Please re-open or correct (I'm pretty sure Mauro has fixed this though).
Comment 3 Alistair Strachan 2008-05-12 09:08:55 UTC
Created attachment 16116 [details]
Fixes I2C=n build bug

The build bug is still present in -rc2. This stop-gap patch fixes it, but as I've explained more than once during the thread on LKML, tuner-core should NOT be built if there are no tuners selected, even IF I2C is enabled.
Comment 4 Adrian Bunk 2008-05-15 08:45:36 UTC
seems to be fixed by the latest V4L/DVB pull

Note You need to log in before you can comment on or make changes to this bug.