Bug 10623 - k8-bus_64.c(?) spams dmesg in 2.6.26-rc1
k8-bus_64.c(?) spams dmesg in 2.6.26-rc1
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: Yinghai Lu
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 12:02 UTC by Rafael J. Wysocki
Modified: 2008-05-11 14:12 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-08 12:02:42 UTC
Subject    : k8-bus_64.c(?) spams dmesg in 2.6.26-rc1
Submitter  : Jeff Garzik <jeff@garzik.org>
Date       : 2008-05-04 07:28
References : http://lkml.org/lkml/2008/5/4/78
Handled-By : "Yinghai Lu" <yhlu.kernel@gmail.com>
Patch      :

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Yinghai Lu 2008-05-08 13:03:21 UTC
http://git.kernel.org/?p=linux/kernel/git/x86/linux-2.6-x86.git;a=commitdiff;h=492782e3e9e32ec89949610e4ffdbfced7d92363

x86: remove spew print out about bus to node mapping
Yinghai Lu [Sun, 4 May 2008 20:41:02 +0000 (13:41 -0700)]
Jeff Garzik pointed out that this printout is not needed.

Signed-off-by: Yinghai Lu <yhlu.kernel@gmail.com>
Signed-off-by: Ingo Molnar <mingo@elte.hu>

arch/x86/pci/k8-bus_64.c 		patch | blob | history

diff --git a/arch/x86/pci/k8-bus_64.c b/arch/x86/pci/k8-bus_64.c
index ab6d4b1..5c2799c 100644 (file)
--- a/arch/x86/pci/k8-bus_64.c
+++ b/arch/x86/pci/k8-bus_64.c
@@ -504,14 +504,6 @@ static int __init early_fill_mp_bus_info(void)
                }
        }
 
-#ifdef CONFIG_NUMA
-       for (i = 0; i < BUS_NR; i++) {
-               node = mp_bus_to_node[i];
-               if (node >= 0)
-                       printk(KERN_DEBUG "bus: %02x to node: %02x\n", i, node);
-       }
-#endif
-
        for (i = 0; i < pci_root_num; i++) {
                int res_num;
                int busnum;

Note You need to log in before you can comment on or make changes to this bug.