Bug 10622 - [BUG 2.6.26-rc1] scsi (or sysfs or vm?) oops in sr_probe()
[BUG 2.6.26-rc1] scsi (or sysfs or vm?) oops in sr_probe()
Status: CLOSED UNREPRODUCIBLE
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-08 11:59 UTC by Rafael J. Wysocki
Modified: 2008-05-24 14:22 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-08 11:59:02 UTC
Subject    : [BUG 2.6.26-rc1] scsi (or sysfs or vm?) oops in sr_probe()
Submitter  : Jeff Garzik <jeff@garzik.org>
Date       : 2008-05-04 07:22
References : http://lkml.org/lkml/2008/5/4/76
Handled-By : James Bottomley <James.Bottomley@hansenpartnership.com>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-08 12:06:30 UTC
Regressions list annotation:
Handled-By : Dan Williams <dan.j.williams@intel.com>
Patch : http://marc.info/?l=linux-raid&m=121001065404056&w=2
Comment 2 Dan Williams 2008-05-08 16:55:59 UTC
The patch at http://marc.info/?l=linux-raid&m=121001065404056&w=2 addresses a different issue: "WARNING: at include/linux/blkdev.h:443"
Comment 3 Rafael J. Wysocki 2008-05-09 05:43:58 UTC
Regressions list annotation:
Ignore-Patch : http://marc.info/?l=linux-raid&m=121001065404056&w=2
Comment 4 Rafael J. Wysocki 2008-05-24 14:21:50 UTC
James Bottomley said:

"I've been unable to get the reporter to respond to basic debugging
inquiries about this.  Without that information, my best guess is that
it's a kmalloc failure that ordinarily would be a mm issue.  However,
given that there have been no other reports of this, I suspect it might
be some type of one off error.

I'd downgrade the severity to not reproducible and kill it unless any
further information comes along."

References : http://lkml.org/lkml/2008/5/22/485

Note You need to log in before you can comment on or make changes to this bug.