Bug 10606 - 2.6.26-rc1 regression: ACPI fails to load SDT. - Dell M1530
2.6.26-rc1 regression: ACPI fails to load SDT. - Dell M1530
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Config-Tables
All Linux
: P1 normal
Assigned To: Robert Moore
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-05 18:11 UTC by Nigel Cunningham
Modified: 2008-06-13 19:44 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments
Kernel config used to build the failing kernel. (53.78 KB, text/plain)
2008-05-05 18:12 UTC, Nigel Cunningham
Details
acpidump output (98.85 KB, text/plain)
2008-05-05 18:54 UTC, Nigel Cunningham
Details
2.6.26-rc1 dmesg (27.34 KB, text/plain)
2008-05-06 05:06 UTC, Nigel Cunningham
Details
2.6.25.1 dmesg (36.80 KB, text/plain)
2008-05-06 05:09 UTC, Nigel Cunningham
Details
patch to allow zero-length field lists (541 bytes, patch)
2008-05-07 12:50 UTC, Robert Moore
Details | Diff

Description Nigel Cunningham 2008-05-05 18:11:05 UTC
Latest working kernel version: 2.6.25
Earliest failing kernel version: 2.6.26-rc1
Distribution: Ubuntu Hardy
Hardware Environment: Dell M1530 laptop
Problem Description:

Under 2.6.26-rc1:
[    0.150224] ACPI: Core revision 20080321
[    0.153815] ACPI Exception (tbxface-0629): AE_AML_NO_OPERAND, While loading namespace from ACPI tables [20080321]
[    0.153818] ACPI: Unable to load the System Description Tables

Under 2.6.25:
ACPI: Core revision 20070126
Using local APIC timer interrupts.
APIC timer calibration result 12468730
Comment 1 Nigel Cunningham 2008-05-05 18:12:40 UTC
Created attachment 16031 [details]
Kernel config used to build the failing kernel.
Comment 2 Len Brown 2008-05-05 18:33:49 UTC
please attach the output from acpidump
Comment 3 Nigel Cunningham 2008-05-05 18:54:10 UTC
Created attachment 16032 [details]
acpidump output

As requested :)
Comment 4 ykzhao 2008-05-05 23:08:15 UTC
Hi, 
   Will you please attach the output of dmesg on kernel 2.6.26-rc1 with acpi enabled?
   It will be great if you can attach the output of dmesg on kernel 2.6.25.
   Thanks.
Comment 5 Nigel Cunningham 2008-05-06 05:06:50 UTC
Created attachment 16045 [details]
2.6.26-rc1 dmesg
Comment 6 Nigel Cunningham 2008-05-06 05:09:03 UTC
Created attachment 16046 [details]
2.6.25.1 dmesg
Comment 7 Rafael J. Wysocki 2008-05-06 15:19:48 UTC
This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 8 Robert Moore 2008-05-06 17:43:10 UTC
Apparently the interpreter cannot handle a Field() operator with a null field list. The code causing problems is:

OperationRegion (KBMP, SystemMemory, 0xFF800180, 0x70)
Field (KBMP, ByteAcc, Lock, Preserve)
{
}

Fix forthcoming. This affects the disassembler also, since it uses the same code.
Comment 9 Nigel Cunningham 2008-05-06 19:35:04 UTC
Terrific! Looking forward to it, and thanks for your quick responses.
Comment 10 Robert Moore 2008-05-07 12:50:53 UTC
Created attachment 16061 [details]
patch to allow zero-length field lists

This patch allows the table to load here, please give it a try.
Comment 11 Nigel Cunningham 2008-05-07 15:48:04 UTC
That patch works fine. Thanks!
Comment 12 Nigel Cunningham 2008-05-07 16:20:43 UTC
Oh, sorry Rafael. Just read your comment and clicked that I did the wrong thing since the patch isn't in mainline yet. Reopening.
Comment 13 Rafael J. Wysocki 2008-05-12 12:20:32 UTC
Regressions list annotation:
Patch : http://bugzilla.kernel.org/attachment.cgi?id=16061&action=view
Comment 14 Rafael J. Wysocki 2008-05-20 15:30:02 UTC
Nigel said:

"(cd /usr/src/cg-head; gitk drivers/acpi) after pulling from Linus' tree
doesn't show it yet."

References : http://lkml.org/lkml/2008/5/18/328

Closing.
Comment 15 Rafael J. Wysocki 2008-05-20 16:17:14 UTC
Ah, I misread the Nigel's comment, sorry.
Comment 16 Shaohua 2008-05-28 00:47:55 UTC
patch is in acpica tree
Comment 17 Nigel Cunningham 2008-05-28 02:52:14 UTC
Yes, but as per comment #7, we're not supposed to close it until the patch reaches mainline. Any ETA?
Comment 18 Rafael J. Wysocki 2008-05-29 14:15:05 UTC
Problem is present in 2.6.26-rc4.
References : http://lkml.org/lkml/2008/5/26/3
Comment 19 Rafael J. Wysocki 2008-06-05 14:17:37 UTC
Confirmed to be present in 2.6.26-rc4-git4.
References : http://lkml.org/lkml/2008/6/2/524
Comment 20 Nigel Cunningham 2008-06-05 14:39:23 UTC
Err. That should be not present (not yet in mainline). Should I just ignore your requests for status and close the bug when it _is_ merged? (I am watching for it)?
Comment 21 Rafael J. Wysocki 2008-06-05 15:06:16 UTC
(In reply to comment #20)
> Err. That should be not present (not yet in mainline).

No, i meant the _problem_ was present in that kernel, not the patch. :-)

> Should I just ignore your requests for status and close the bug when it
> _is_ merged? (I am watching for it)?

Yes, please.
Comment 22 Nigel Cunningham 2008-06-11 18:01:00 UTC
Patch just hit mainline.

Thank you!
Comment 23 Len Brown 2008-06-13 18:59:12 UTC
shipped in 2.56.26-rc6:

commit 7e7c9052a617ea6086144a4fbda262d32a100479
Author: Bob Moore <robert.moore@intel.com>
Date:   Tue Jun 10 13:00:32 2008 +0800

    ACPICA: Fix to allow zero-length ASL field declarations
Comment 24 Nigel Cunningham 2008-06-13 19:44:18 UTC
(2.6.26-rc6, that is)

Note You need to log in before you can comment on or make changes to this bug.