Bug 10584 - Apple Aluminium keyboards needs not to use the numlock emulation
Summary: Apple Aluminium keyboards needs not to use the numlock emulation
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jiri Kosina
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-01 08:42 UTC by Diego Elio Pettenò
Modified: 2008-05-29 05:52 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25
Tree: Mainline
Regression: Yes


Attachments
apple-aluminium-keyboard-no-numlock.patch (6.67 KB, patch)
2008-05-01 08:44 UTC, Diego Elio Pettenò
Details | Diff

Description Diego Elio Pettenò 2008-05-01 08:42:37 UTC
Latest working kernel version: 2.6.24
Earliest failing kernel version: 2.6.25
Distribution: Gentoo Linux
Hardware Environment: Apple Aluminium Keyboard
Software Environment: N/A
Problem Description: Since 2.6.25 added support for Apple Aluminium keyboards, I've enabled it, but the quirks enabled are the same as Apple laptops' keyboards, which means they have numlock software emulation. This software emulation is not useful at all for Aluminium keyboards, and actually makes them unusable once Numlock is enabled.

Steps to reproduce: Enable Apple keyboard support in kernel 2.6.25, connect an Apple Aluminium keyboard and enable numlock.

I'm going to attach a patch that splits out the numlock emulation quirk, so that it's only enabled if requested, and requests it for all the models beside the Aluminium (so that the previous behaviour is maintained for all of them).

HTH,
Diego Pettenò
Comment 1 Diego Elio Pettenò 2008-05-01 08:44:19 UTC
Created attachment 16001 [details]
apple-aluminium-keyboard-no-numlock.patch
Comment 2 Diego Elio Pettenò 2008-05-01 08:53:42 UTC
Now that I think of it, though, it's possible that the Apple Aluminium Wireless still needs the numlock software emulation, as it doesn't have an actual numeric pad... but I don't have the hardware to test that :/
Comment 3 Anonymous Emailer 2008-05-01 14:27:15 UTC
Reply-To: akpm@linux-foundation.org


oh dear.  It's really really awkward to handle patches via bugzilla.

Could you please send the patch as a regular emailed patch as per
Documentation/SubmittingPatches to:

	Jiri Kosina <jkosina@suse.cz>
	linux-input@vger.kernel.org
	Andrew Morton <akpm@linux-foundation.org>

?

Thanks.
Comment 4 Jiri Kosina 2008-05-29 05:52:34 UTC
Fixed by mainline commit 6e7045990f35ef9250804b3fd85e855b8c2aaeb6, closing.

Note You need to log in before you can comment on or make changes to this bug.