Bug 105781 - GPE flooding prevention - gpe06 interrupt storm on Macbook Pro (late 2013)
Summary: GPE flooding prevention - gpe06 interrupt storm on Macbook Pro (late 2013)
Status: CLOSED DUPLICATE of bug 117481
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-11 10:50 UTC by Gökçen Eraslan
Modified: 2016-05-16 22:24 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.2.2
Tree: Mainline
Regression: No


Attachments
acpidump (287.71 KB, text/plain)
2015-10-11 10:50 UTC, Gökçen Eraslan
Details
DSDT (27.03 KB, application/octet-stream)
2015-10-11 10:54 UTC, Gökçen Eraslan
Details
Disassambled DSDT (235.54 KB, text/x-dsl)
2015-10-11 10:56 UTC, Gökçen Eraslan
Details
cat /proc/acpi/wakeup (476 bytes, text/plain)
2015-10-12 18:45 UTC, Gökçen Eraslan
Details
Full "dmidecode --no-sysfs" output (13.12 KB, text/plain)
2015-10-13 16:35 UTC, Gökçen Eraslan
Details

Description Gökçen Eraslan 2015-10-11 10:50:39 UTC
Created attachment 189951 [details]
acpidump

I have been experiencing that a kworker thread is hogging CPU for long time:

$ cat /sys/firmware/acpi/interrupts/gpe06
 3058798   enabled

Disabling it solves the problem temporarily:

# echo disable > /sys/firmware/acpi/interrupts/gpe06

There seems to be other people complaining about the same thing:

https://bugzilla.kernel.org/show_bug.cgi?id=85881#c48
https://bugzilla.redhat.com/show_bug.cgi?id=1192856
https://bbs.archlinux.org/viewtopic.php?pid=1500325#p1500325
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1403653
http://teslabs.com/articles/ubuntu-15-04-mbp-11-2/#high-cpu-usage-by-kworker
https://gist.github.com/tombee/c1c225388f261fcddd4b#power-management-issues

acpidump attached, dmidecode gives:

/sys/firmware/dmi/tables/DMI: Unexpected end of file
Table is unreachable, sorry.
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.4 present.
45 structures occupying 2597 bytes.
Table at 0x7AD14000.

PS: Version of OS X installed is 10.11.
Comment 1 Gökçen Eraslan 2015-10-11 10:54:20 UTC
Created attachment 189961 [details]
DSDT

DSDT attached: `sudo cat /sys/firmware/acpi/tables/DSDT`
Comment 2 Gökçen Eraslan 2015-10-11 10:56:19 UTC
Created attachment 189971 [details]
Disassambled DSDT
Comment 3 Zhang Rui 2015-10-12 05:50:13 UTC
please attach the full acpidump.
please attach the output of "cat /proc/acpi/wakeup".
Comment 4 Gökçen Eraslan 2015-10-12 18:45:57 UTC
Created attachment 190101 [details]
cat /proc/acpi/wakeup
Comment 5 Gökçen Eraslan 2015-10-12 18:48:16 UTC
I added "cat /proc/acpi/wakeup" output. acpidump is full already.
Comment 6 Gökçen Eraslan 2015-10-13 16:35:33 UTC
Created attachment 190181 [details]
Full "dmidecode --no-sysfs" output
Comment 7 Gökçen Eraslan 2015-10-14 17:00:29 UTC
Do you need any more information? I cannot remove NEEDINFO flag.
Comment 8 Gökçen Eraslan 2016-01-11 14:10:29 UTC
I can reproduce it even on android-x86. Is anything else needed?
Comment 9 Lv Zheng 2016-05-16 22:24:51 UTC
Same issue as Bug 117481, let's track this there.

*** This bug has been marked as a duplicate of bug 117481 ***

Note You need to log in before you can comment on or make changes to this bug.