Bug 10557 - [regression] latest git couse kernel oops.
Summary: [regression] latest git couse kernel oops.
Status: CLOSED CODE_FIX
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-04-26 00:19 UTC by Oleksij Rempel (fishor)
Modified: 2008-05-25 04:54 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-git8
Tree: Mainline
Regression: Yes


Attachments
foto_trace (400.56 KB, image/jpeg)
2008-04-26 04:20 UTC, Oleksij Rempel (fishor)
Details

Description Oleksij Rempel (fishor) 2008-04-26 00:19:29 UTC
some patch betvene 
commit bad b1721d0da266b4af8cb4419473b4ca36206ab200
and
commit good f360bf0015e5b3e82be61c68e0863b3f98852ee2
make kernel oops on boot. I can't bisect it becouse of compile error.

Kernel: arch/x86/boot/bzImage is ready  (#61)
ERROR: "__locks_copy_lock" [fs/lockd/lockd.ko] undefined!
make[1]: *** [__modpost] Fehler 1
make: *** [modules] Fehler 2

i think  this commit 3dd7b71ca0f7ff8410a6b8cb15e5f670f90181e4
Comment 1 Andrew Morton 2008-04-26 04:09:05 UTC
Please set CONFIG_LOCKD=y to work around this problem and then 
proceed with the bisection, thanks.

Is a copy of the oops trace available?
Comment 2 Oleksij Rempel (fishor) 2008-04-26 04:13:44 UTC
this commit bracke it for me:

commit 3b1253880b7a9e6db54b943b2d40bcf2202f58ab
Author: Al Viro <viro@zeniv.linux.org.uk>
Date:   Tue Apr 22 05:31:30 2008 -0400

    [PATCH] sanitize unshare_files/reset_files_struct
    
    * let unshare_files() give caller the displaced files_struct
    * don't bother with grabbing reference only to drop it in the
      caller if it hadn't been shared in the first place
    * in that form unshare_files() is trivially implemented via
      unshare_fd(), so we eliminate the duplicate logics in fork.c
    * reset_files_struct() is not just only called for current;
      it will break the system if somebody ever calls it for anything
      else (we can't modify ->files of somebody else).  Lose the
      task_struct * argument.
    
    Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
Comment 3 Oleksij Rempel (fishor) 2008-04-26 04:20:38 UTC
Created attachment 15920 [details]
foto_trace

if you steal need a part of trace.
Comment 4 Anonymous Emailer 2008-04-26 04:31:15 UTC
Reply-To: akpm@linux-foundation.org

On Sat, 26 Apr 2008 04:13:44 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10557
> 
> 
> 
> 
> 
> ------- Comment #2 from bug-track@fisher-privat.net  2008-04-26 04:13 -------
> this commit bracke it for me:
> 
> commit 3b1253880b7a9e6db54b943b2d40bcf2202f58ab
> Author: Al Viro <viro@zeniv.linux.org.uk>
> Date:   Tue Apr 22 05:31:30 2008 -0400
> 
>     [PATCH] sanitize unshare_files/reset_files_struct
> 
>     * let unshare_files() give caller the displaced files_struct
>     * don't bother with grabbing reference only to drop it in the
>       caller if it hadn't been shared in the first place
>     * in that form unshare_files() is trivially implemented via
>       unshare_fd(), so we eliminate the duplicate logics in fork.c
>     * reset_files_struct() is not just only called for current;
>       it will break the system if somebody ever calls it for anything
>       else (we can't modify ->files of somebody else).  Lose the
>       task_struct * argument.
> 
>     Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
> 
> 

OK, thanks for doing that.  Al, could you please take a peek at
http://bugzilla.kernel.org/show_bug.cgi?id=10557 ?
Comment 5 Oleksij Rempel (fishor) 2008-05-24 22:28:55 UTC
Seems to be fixed. Tested with 2.6.26-rc3-00416-geb90d81
Comment 6 Andrew Morton 2008-05-24 23:19:17 UTC
ok, thanks, I'll close the report.

Note You need to log in before you can comment on or make changes to this bug.