Bug 105471 - 10ec:8176 rtl8192ce 200-3200+ms latency on 802.11n 2.4GHz network with no load
Summary: 10ec:8176 rtl8192ce 200-3200+ms latency on 802.11n 2.4GHz network with no load
Status: RESOLVED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: networking_wireless@kernel-bugs.osdl.org
URL: https://bugs.launchpad.net/ubuntu/+so...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-04 23:30 UTC by Christopher M. Penalver
Modified: 2016-02-16 17:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.3.0-rc3-wl
Tree: Mainline
Regression: No


Attachments
info.txt (96.63 KB, text/plain)
2015-10-04 23:30 UTC, Christopher M. Penalver
Details
Patch to change delays to sleeps (2.75 KB, patch)
2016-02-16 16:41 UTC, Larry Finger
Details | Diff

Description Christopher M. Penalver 2015-10-04 23:30:22 UTC
Created attachment 189441 [details]
info.txt

[1.] One line summary of the problem:
10ec:8176 rtl8192ce 200-3200+ms latency on 802.11n 2.4GHz network with no load

[2.] Full description of the problem/report:
This is a follow up to http://marc.info/?l=linux-wireless&m=143264578518617&w=2 . With an Asus PCE-N10 PCI-E Adapter Wireless N card (10ec:8176 rtl8192ce) I have 200-3200+ms latency on a 802.11n 2.4GHz network pinging just the gateway 192.168.1.1, with no network load on either the router or the WiFi chipset. The computer is ~4 feet away from a Verizon Jetpack MiFi 5510L with latest firmware installed (L1.34.23 M1.34.20) connected to a power source, with no obstructions between them. Other clients (same version of latest upstream kernel+Ubuntu with different chipset, Windows) don't have this problem.

For example, transferring data to a Windows 8.1 laptop, I obtain ~250Kbps. However, my other laptops consistently transfer to it at 1.5 Mbps.

I've tested both latest mainline (4.3-rc3) and wireless-testing branch as per https://wireless.wiki.kernel.org/en/developers/documentation/git-guide and it's the same old story.

Please see attached info.txt for full debug information.
Comment 1 Christopher M. Penalver 2015-12-15 13:09:46 UTC
This device works flawlessly (i.e. never above 30ms on pings for hours) both in Windows 8.1, and Windows 10. Hence, this is a clearcut upstream linux driver problem.
Comment 2 Larry Finger 2016-02-16 16:41:36 UTC
Created attachment 203741 [details]
Patch to change delays to sleeps

With this patch, which has been pushed upstream, my typical ping results are

rtt min/avg/max/mdev = 1.302/4.134/101.955/10.126 ms

Although that max is greater than what you see for Windows, it seems to be an improvement.

If possible, please test and report your results.
Comment 3 Christopher M. Penalver 2016-02-16 17:39:31 UTC
Larry Finger, thanks for your hard work towards this.

Given you have confirmed an improvement, and it was submitted upstream, I'll close this report as fixed.

Please adjust the Status if inappropriate.

Note You need to log in before you can comment on or make changes to this bug.