Bug 105111 - amdgpu 0000:00:01.0: Invalid ROM contents (with A8-7600)
Summary: amdgpu 0000:00:01.0: Invalid ROM contents (with A8-7600)
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: IA-64 Linux
: P1 blocking
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-28 08:19 UTC by fin4478
Modified: 2018-12-05 02:32 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.3.0-rc3
Tree: Mainline
Regression: No


Attachments
dmesg output (48.01 KB, text/plain)
2015-09-28 08:19 UTC, fin4478
Details
Amd Catalyst bios information with kernel 4.1.6 (96.93 KB, image/png)
2015-09-28 15:36 UTC, fin4478
Details

Description fin4478 2015-09-28 08:19:13 UTC
Created attachment 188721 [details]
dmesg output

amdgpu fails to find bios rom in Amd A8-7600 system. The following is a dmesg capture after booting to linux rescue mode:

[    1.629958] [drm] amdgpu kernel modesetting enabled.
[    1.630360] [drm] initializing kernel modesetting (KAVERI 0x1002:0x1313 0x1043:0x85CB 0x00).
[    1.630410] [drm] register mmio base: 0xFEB00000
[    1.630445] [drm] register mmio size: 262144
[    1.630487] [drm] doorbell mmio base: 0xF0000000
[    1.630523] [drm] doorbell mmio size: 8388608
[    1.630582] amdgpu 0000:00:01.0: Invalid ROM contents
[    1.630652] [drm:amdgpu_get_bios [amdgpu]] *ERROR* Unable to locate a BIOS ROM
[    1.630695] amdgpu 0000:00:01.0: Fatal error during GPU init
[    1.630732] [drm] amdgpu: finishing device.
[    1.630767] [TTM] Memory type 2 has not been initialized
[    1.632024] amdgpu: probe of 0000:00:01.0 failed with error -22

Problematic code is in the file: drivers/gpu/drm/amd/amdgpu/amdgpu_bios.c
Comment 1 Alex Deucher 2015-09-28 13:50:39 UTC
Is this a regression?  If so, can you bisect?
Comment 2 fin4478 2015-09-28 15:34:50 UTC
(In reply to Alex Deucher from comment #1)
> Is this a regression?  If so, can you bisect?

Same bug is in kernel 4.3-rc1 that i try before rc3. Amd Catalyst 15.201 works ok with kernel 4.1.6 and can found bios information.
Comment 3 fin4478 2015-09-28 15:36:51 UTC
Created attachment 188771 [details]
Amd Catalyst bios information with kernel 4.1.6
Comment 4 Alex Deucher 2015-09-28 22:29:44 UTC
Does the open driver work with kernel 4.1.6?
Comment 5 fin4478 2015-09-29 03:44:35 UTC
(In reply to Alex Deucher from comment #4)
> Does the open driver work with kernel 4.1.6?

amdgpu does not exist in kernel 4.1.6, it came to kernel in version 4.2 or something. And integrated graphics support is a very new feature in amdgpu, you have experimental CONFIG_DRM_AMDGPU_CIK in the .config file.
Comment 6 Michel Dänzer 2015-09-29 06:12:04 UTC
(In reply to fin4478 from comment #5)
> amdgpu does not exist in kernel 4.1.6, [...]

The radeon driver (CONFIG_DRM_RADEON) supports your GPU. The CIK support in amdgpu is experimental and not intended for end users.
Comment 7 fin4478 2015-09-29 06:43:38 UTC
(In reply to Michel Dänzer from comment #6)
> (In reply to fin4478 from comment #5)
> > amdgpu does not exist in kernel 4.1.6, [...]
> 
> The radeon driver (CONFIG_DRM_RADEON) supports your GPU. The CIK support in
> amdgpu is experimental and not intended for end users.
CONFIG_DRM_AMDGPU_CIK: 
"CIK support in amdgpu
is for experimentation and testing."

I tested and reported. Catalyst gives better fps and quality than radeon, see:
http://www.phoronix.com/scan.php?page=article&item=radeonsi-cat-wow&num=2
" However, when looking at the each driver's rendering of the game, with Catalyst there was greater detail than with the RadeonSI Gallium3D driver.

"
Comment 8 Christian König 2015-09-29 08:10:02 UTC
CIK support in Amdgpu was for developer bringup and not intended for end user usage.

The Radeon driver is the intended one for end users for this hardware generation.

We should probably remove CIK support or otherwise will get even more bug reports like this.

Note You need to log in before you can comment on or make changes to this bug.