Bug 104711 - wireless connection reset
Summary: wireless connection reset
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Mips32 Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-17 11:14 UTC by Vincent Fortier
Modified: 2015-09-17 13:46 UTC (History)
2 users (show)

See Also:
Kernel Version: Possibly kernel 3.3 up to 3.18+
Tree: Mainline
Regression: No


Attachments

Description Vincent Fortier 2015-09-17 11:14:38 UTC
Experienced on all tested openwrt releases in the past two years using TP-Link TL-WDR4300 v1 hardware.  Very often connection drops for WIFI connected client devices.  For instance using my WIFI connected laptop on either ubuntu/android/windows will drop and reconnect very often (sometime almost not at all while up to every few minutes).  Same with WIFI connected android smartphones as it can use mobile service it is usually seemless (except for the monthly bill afterwards).

From my experience I noted that the bug "seems" to be more frequent after longer uptime of my wireless router.  After a month of usage I clearly see full connection drops every now and then while the next few days after a reset all client devices seems to run rather smoothly.

I've found a bug entry in openwrt which I presume is related:
https://dev.openwrt.org/ticket/7750

Someone noted that disabling LNAs within the driver code seems to fix the issue.
https://dev.openwrt.org/ticket/7750#comment:39

Thnx in advance for looking into this!
Comment 1 John W. Linville 2015-09-17 13:46:48 UTC
Honestly, this sounds more like something you should pursue with the openwrt project...

Note You need to log in before you can comment on or make changes to this bug.