Bug 104641 - i2c designware driver caused system to hang during boot and poweroff
Summary: i2c designware driver caused system to hang during boot and poweroff
Status: RESOLVED DUPLICATE of bug 101271
Alias: None
Product: Drivers
Classification: Unclassified
Component: I2C (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: Mika Westerberg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 06:40 UTC by Keng-Yu Lin
Modified: 2016-08-10 16:31 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.17 to 4.2
Tree: Mainline
Regression: No


Attachments
cpuinfo (3.64 KB, text/x-log)
2015-09-16 06:40 UTC, Keng-Yu Lin
Details

Description Keng-Yu Lin 2015-09-16 06:40:12 UTC
Created attachment 187711 [details]
cpuinfo

i2c designware driver causes to hang during booting, fail rate 80%. And when it boots, it can't poweroff or reboot normally.

This happens with all versions above 3.17.0. It is because from 3.17.0, Linux kernel adds BSW bindings for i2c-designware driver (commit 0409516 i2c: designware: add new bindings), so x360 will load i2c-designware-* modules[1] and it hangs when boot. And when it hangs, there's no any code trace. Caps lock led and SysRq both can not work.

When it can boot and doing poweroff or reboot, after stoping service it turns to black screen, but can not turn power off, and stays in the states. This also happens if we blacklist i2c-designware-* modules when boot and modprobe them back.

After blacklist i2c-designware-* modules, it can also boot, reboot, and poweroff normally.

[1]: Includes i2c-designware-core and i2c-designware-platform. X360 i2c uses ACPI interface rather then pci, so i2c-designware-pci is not loaded.
Comment 1 Mika Westerberg 2015-09-22 08:30:56 UTC
Can you attach full dmesg to this bug?

Also do you have dw_dmac (DesignWare DMA) driver loaded? If yes, can you try first disable following from your kernel .config:

CONFIG_DW_DMAC_CORE=n
CONFIG_DW_DMAC=n
CONFIG_DW_DMAC_PCI=n

We have outstanding bug which hangs the system in certain occasions and it is actually related to DMA not I2C.
Comment 2 Mika Westerberg 2015-09-22 13:27:48 UTC
Alternatively you can blacklist dw_dmac if you don't want to recompile the kernel.
Comment 3 Andy Shevchenko 2016-01-27 18:06:21 UTC
v4.5-rc1 is out. Please, re-check on it.
Comment 4 Andy Shevchenko 2016-08-10 16:31:27 UTC
No info for a long time. Close as duplicate of bug #101271 since the symptoms are very similar.

Please, feel free to re-open the bug in case it occurs with an additional info provided as Mika asked for.

*** This bug has been marked as a duplicate of bug 101271 ***

Note You need to log in before you can comment on or make changes to this bug.