Bug 104341 - Audio crackles on Dell Latitude E6540
Summary: Audio crackles on Dell Latitude E6540
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
: 108391 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-09 19:57 UTC by Havran
Modified: 2016-01-15 13:21 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.1, 4.2, 4.3
Tree: Mainline
Regression: No


Attachments
Output from alsa-info.sh (44.63 KB, application/octet-stream)
2015-09-09 19:57 UTC, Havran
Details
Fix patch (830 bytes, patch)
2015-09-11 12:50 UTC, Takashi Iwai
Details | Diff

Description Havran 2015-09-09 19:57:07 UTC
Created attachment 187191 [details]
Output from alsa-info.sh

Crackles occurs with the 4.1 and 4.2 kernels on Dell Latitude E6540.
Looks similar to bug 100571.
Comment 1 Takashi Iwai 2015-09-11 12:49:39 UTC
Does the patch below work as expected?
Comment 2 Takashi Iwai 2015-09-11 12:50:06 UTC
Created attachment 187331 [details]
Fix patch
Comment 3 Havran 2015-09-20 20:15:16 UTC
 Crackling is gone with this patch. Thanks.
Comment 4 Havran 2015-10-04 17:49:42 UTC
Will the patch be added into the kernel?
Comment 5 Havran 2015-11-09 17:51:55 UTC
The bug still persist in kernel 4.3
Comment 6 corentin.dehay 2015-12-03 23:27:08 UTC
The bug still persist in kernel 4.4 (i've the same dell E6540)
Comment 7 corentin.dehay 2015-12-03 23:31:52 UTC
*** Bug 108391 has been marked as a duplicate of this bug. ***
Comment 8 corentin.dehay 2015-12-04 13:43:01 UTC
I don't find how to apply the patch , any help ?
Comment 9 Raymond 2015-12-04 23:37:06 UTC
(In reply to Havran from comment #0)
> Created attachment 187191 [details]
> Output from alsa-info.sh
> 
> Crackles occurs with the 4.1 and 4.2 kernels on Dell Latitude E6540.
> Looks similar to bug 100571.

XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
Comment 10 Havran 2015-12-05 16:11:53 UTC
(In reply to Raymond from comment #9)
> XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid
> 1000! (This could e g happen if you try to connect to a non-root PulseAudio
> as a root user, over the native protocol. Don't do that.)

Hi Raymond, i think this is not related to the bug.

Takashi, could you please submit the patch into upstream?
Comment 11 corentin.dehay 2016-01-15 11:51:02 UTC
Hi ,

I've tried the new LTS kernel 4.4 , and it still happening.
Comment 12 Takashi Iwai 2016-01-15 13:19:14 UTC
Oops, sorry, this one was forgotten during vacation.  I'll merge the fix for 4.5, eventually backported to stable kernels later.
Comment 13 corentin.dehay 2016-01-15 13:21:07 UTC
Don't worry, it's not a big problem.
Thanks for the fix !

Note You need to log in before you can comment on or make changes to this bug.