Bug 10428 - [rc8] Regression: key repeats and skips in music during compilation
Summary: [rc8] Regression: key repeats and skips in music during compilation
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-04-08 15:26 UTC by Rafael J. Wysocki
Modified: 2008-04-14 15:04 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.25-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-04-08 15:26:09 UTC
Subject    : [rc8] Regression: key repeats and skips in music during compilation
Submitter  : Frans Pop <elendil@planet.nl>
Date       : 2008-04-04 12:22
References : http://lkml.org/lkml/2008/4/4/83
Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>
Handled-By : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Andrew Clayton 2008-04-09 01:50:06 UTC
This really does sound like something I've been seeing post 2.6.25-rc5

Audio will stutter when doing a kernel compile It does also happen when not much else is seemingly going on. When it happens the desktop also seems to stutter momentarily. Also while playing Frets on Fire, there are a periodic stutters. However I'm not seeing key repeats.

2.6.25-rc5 is fine (IIRC 2.6.25-rc5-git5 is also OK)
2.6.25-rc6 is bad. Under this kernel the music will stutter for a second then rhythmbox will be locked up consuming 99% cpu. IIRC from a strace, doing lot's of futex stuff.
2.6.25-rc8 is slightly less worse in that rhythmbox doesn't lock up.

Last tried kernel is 2.6.25-rc8-git6

System is a single CPU AMD Athlon XP 1800+ running Fedora 8
Comment 2 Frans Pop 2008-04-09 09:43:43 UTC
Bug has been traced to this change (committed between -rc5 and -rc6):

commit e22ecef1d2658ba54ed7d3fdb5d60829fb434c23
Author: Ingo Molnar <mingo@elte.hu>
Date:   Fri Mar 14 22:16:08 2008 +0100

    sched: fix fair sleepers

    Fair sleepers need to scale their latency target down by runqueue
    weight. Otherwise busy systems will gain ever larger sleep bonus.

Verified by reverting that patch on top of -rc8. Audio skips disappeared.

Thanks to Peter for providing a patch series to test with.
Comment 3 Adrian Bunk 2008-04-14 15:04:33 UTC
fixed by commit e2df9e0905136eebeca66eb9a994ca48d0fa7990

Note You need to log in before you can comment on or make changes to this bug.