Bug 10427 - e1000e broke e1000
Summary: e1000e broke e1000
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jesse Brandeburg
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-04-08 14:27 UTC by Rafael J. Wysocki
Modified: 2009-02-26 11:47 UTC (History)
4 users (show)

See Also:
Kernel Version: head 7180c4c9e09888db0a188f729c96c6d7bd61fa83
Tree: Mainline
Regression: Yes


Attachments
fix patch (1.31 KB, patch)
2008-04-09 13:46 UTC, Ingo Molnar
Details | Diff

Description Rafael J. Wysocki 2008-04-08 14:27:01 UTC
Subject    : e1000e broke e1000
Submitter  : Ingo Molnar <mingo@elte.hu>
Date       : 2008-04-08 20:39
References : http://lkml.org/lkml/2008/4/8/256

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Auke Kok 2008-04-09 09:14:42 UTC
This bug is invalid, per design users have to switch to e1000e for some of the devices previously supported by e1000. This is _not_ a regression, only a migration problem.
Comment 2 Rafael J. Wysocki 2008-04-09 13:10:01 UTC
Closing.

Ingo, please reopen if you see fit.
Comment 3 Ingo Molnar 2008-04-09 13:46:52 UTC
Created attachment 15704 [details]
fix patch

this patch fixes the problem for me.
Comment 4 Ingo Molnar 2008-04-09 13:48:33 UTC
a "migration problem" that resulted in a non-working networking interface and caused me more than 1 hour of debugging is a very good example of how we define regressions ...
Comment 5 Rafael J. Wysocki 2008-04-09 14:19:27 UTC
Regressions list annotation:
Patch : http://bugzilla.kernel.org/attachment.cgi?id=15704&action=view
Comment 6 Rafael J. Wysocki 2008-04-17 13:37:00 UTC
Confirmed to be present in 2.6.25-rc9.

References : http://lkml.org/lkml/2008/4/14/46
Comment 7 Jesse Brandeburg 2008-10-06 12:29:46 UTC
seems like we should still fix this?
Comment 8 Adrian Bunk 2008-10-08 05:18:40 UTC
Especially after commit d03157babed7424f5391af43200593768ce69c9a the only reasonable action seems to be a resolution as WILL_NOT_FIX.
Comment 9 Jesse Brandeburg 2009-02-26 11:46:24 UTC
this bug can be closed, the patch suggested won't even work any more because the device ID's were all moved over to e1000e.

Note You need to log in before you can comment on or make changes to this bug.