Bug 10411 - [PATCH] scsi: fix sense_slab/bio swapping livelock
[PATCH] scsi: fix sense_slab/bio swapping livelock
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-04-07 02:15 UTC by Rafael J. Wysocki
Modified: 2008-04-07 09:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-04-07 02:15:40 UTC
Subject    : [PATCH] scsi: fix sense_slab/bio swapping livelock
Submitter  : Hugh Dickins <hugh@veritas.com>
Date       : 2008-04-06 23:56
References : http://lkml.org/lkml/2008/4/6/99
Handled-By : James Bottomley <James.Bottomley@hansenpartnership.com>
Patch      : http://lkml.org/lkml/2008/4/6/99

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-04-07 02:16:51 UTC
James Bottomley said:

This was sort of accidentally fixed in scsi-misc by commit 

commit c5f73260b289cb974928eac05f2d84e58ddfc020
Author: James Bottomley <James.Bottomley@HansenPartnership.com>
Date:   Thu Mar 13 11:16:33 2008 -0500

    [SCSI] consolidate command allocation in a single place
Comment 2 Adrian Bunk 2008-04-07 09:01:16 UTC
fixed by commit 164fc5dcd6a1026fc713f5c63fad899aa484888c

Note You need to log in before you can comment on or make changes to this bug.