Bug 10394 - [>=2.6.23][BUG] Oops on power
[>=2.6.23][BUG] Oops on power
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: Venkatesh Pallipadi
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 05:48 UTC by Aditya Naga Sanjeevi
Modified: 2008-06-12 01:31 UTC (History)
7 users (show)

See Also:
Kernel Version: >=2.6.23
Tree: Mainline
Regression: ---


Attachments
dmesg (24.79 KB, text/plain)
2008-04-05 05:52 UTC, Aditya Naga Sanjeevi
Details
dmesg - 2.6.25-rc8 (29.26 KB, text/plain)
2008-04-05 05:54 UTC, Aditya Naga Sanjeevi
Details
acpidump (118.84 KB, text/plain)
2008-04-05 06:07 UTC, Aditya Naga Sanjeevi
Details
dmesg of 2.6.25-rc8 with kobject-debug (118.55 KB, text/plain)
2008-04-06 10:28 UTC, Aditya Naga Sanjeevi
Details
Oops on 2.6.25-rc8 with kobject-debug (5.34 KB, text/plain)
2008-04-06 10:29 UTC, Aditya Naga Sanjeevi
Details
modules listing (3.07 KB, text/plain)
2008-04-07 18:36 UTC, Aditya Naga Sanjeevi
Details
dmesg of 2.6.25 (122.77 KB, text/plain)
2008-04-22 13:37 UTC, Aditya Naga Sanjeevi
Details
dmesg of 2.6.25 on power disconnection (122.90 KB, text/plain)
2008-04-22 13:37 UTC, Aditya Naga Sanjeevi
Details
syslogd on power disconnection (2.99 KB, text/plain)
2008-04-22 13:38 UTC, Aditya Naga Sanjeevi
Details
Patch to fix oops AC<->Battery (5.77 KB, patch)
2008-05-01 12:03 UTC, Venkatesh Pallipadi
Details | Diff

Description Aditya Naga Sanjeevi 2008-04-05 05:48:35 UTC
Latest working kernel version: 2.6.21
Earliest failing kernel version: 2.6.23
Distribution: Fedora 8
Hardware Environment: Toshiba Satellite L35
Software Environment: Fedora 8
Problem Description: Kernel Oops when switching from A/c Power to Batter Power or when booting while running on a battery. System continues to work after switching from A/c power to batter power, however commands like kill, poweroff, X, etc doesn't work.

Steps to reproduce: disconnect power while working or run on a battery
Comment 1 Aditya Naga Sanjeevi 2008-04-05 05:52:52 UTC
Created attachment 15611 [details]
dmesg

dmesg for 2.6.24-3
Comment 2 Aditya Naga Sanjeevi 2008-04-05 05:54:25 UTC
Created attachment 15612 [details]
dmesg - 2.6.25-rc8

dmesg for 2.6.25-rc8
Comment 3 Aditya Naga Sanjeevi 2008-04-05 05:57:27 UTC
Oops on 2.6.24.3

WARNING: at lib/kref.c:33 kref_get() (Not tainted)
Pid: 69, comm: kacpi_notify Not tainted 2.6.24.3 #5
 [<c04ff274>] kref_get+0x3d/0x45
 [<c04fe65d>] kobject_get+0xf/0x13
 [<c04fe84d>] kobject_add+0x82/0x176
 [<c04fe9eb>] kobject_register+0x19/0x2d
 [<c05b0ad0>] cpuidle_add_state_sysfs+0x7b/0xe4
 [<c052660e>] acpi_os_execute_notify+0x0/0x2b
 [<c05b03fd>] cpuidle_enable_device+0x31/0x9b
 [<c0545923>] acpi_processor_cst_has_changed+0x40/0x55
 [<c0543ae2>] acpi_processor_notify+0x8b/0xf4
 [<c052bcbb>] acpi_ev_notify_dispatch+0x4c/0x55
 [<c0526630>] acpi_os_execute_notify+0x22/0x2b
 [<c052660e>] acpi_os_execute_notify+0x0/0x2b
 [<c043c212>] run_workqueue+0x7d/0x107
 [<c043fa5b>] prepare_to_wait+0x28/0x45
 [<c043c35a>] worker_thread+0xbe/0xca
 [<c043f8ff>] autoremove_wake_function+0x0/0x35
 [<c043c29c>] worker_thread+0x0/0xca
 [<c043f679>] kthread+0x38/0x5d
 [<c043f641>] kthread+0x0/0x5d
 [<c0406477>] kernel_thread_helper+0x7/0x10
 =======================
BUG: unable to handle kernel NULL pointer dereference at virtual address 00000020
printing eip: c04c4716 *pde = 578c2067 
Oops: 0000 [#1] SMP 
Modules linked in: cbc(U) geode_aes(U) blkcipher(U) aes_i586(U) aes_generic(U) dm_crypt(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) autofs4(U) nf_conntrack_ipv4(U) xt_state(U) nf_conntrack(U) xt_tcpudp(U) ipt_REJECT(U) iptable_filter(U) ip_tables(U) x_tables(U) cpufreq_ondemand(U) acpi_cpufreq(U) fuse(U) loop(U) dm_mirror(U) dm_multipath(U) dm_mod(U) ipv6(U) snd_hda_intel(U) snd_seq_dummy(U) snd_seq_oss(U) snd_seq_midi_event(U) snd_seq(U) snd_seq_device(U) snd_pcm_oss(U) sr_mod(U) snd_mixer_oss(U) snd_pcm(U) 8139cp(U) snd_timer(U) button(U) 8139too(U) mii(U) snd_page_alloc(U) cdrom(U) video(U) output(U) snd_hwdep(U) ac(U) snd(U) pcspkr(U) i2c_piix4(U) i2c_core(U) battery(U) joydev(U) soundcore(U) sg(U) pata_atiixp(U) pata_acpi(U) sata_sil(U) ata_generic(U) libata(U) sd_mod(U) scsi_mod(U) ext3(U) jbd(U) mbcache(U) uhci_hcd(U) ohci_hcd(U) ehci_hcd(U)

Pid: 69, comm: kacpi_notify Not tainted (2.6.24.3 #5)
EIP: 0060:[<c04c4716>] EFLAGS: 00010246 CPU: 0
EIP is at sysfs_addrm_start+0x21/0x81
EAX: c04c47d7 EBX: 00000000 ECX: 00000000 EDX: f78b8000
ESI: f78b8eb8 EDI: f78b8ec8 EBP: 00000000 ESP: f78b8ea4
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process kacpi_notify (pid: 69, ti=f78b8000 task=f78d8000 task.ti=f78b8000)
Stack: f229ff54 f229ff54 f5b8d390 fffffff4 c04c4b45 00000000 00000000 00000000 
       00000000 f229ff54 00000000 00000000 f782601c c04c4bab f78b8ee0 c04fe65d 
       f229ff54 c04fe8a8 f722e67f ffffffff ffffffff 00000007 f722e678 f78261d8 
Call Trace:
 [<c04c4b45>] create_dir+0x33/0x6c
 [<c04c4bab>] sysfs_create_dir+0x2d/0x40
 [<c04fe65d>] kobject_get+0xf/0x13
 [<c04fe8a8>] kobject_add+0xdd/0x176
 [<c04fe9eb>] kobject_register+0x19/0x2d
 [<c05b0ad0>] cpuidle_add_state_sysfs+0x7b/0xe4
 [<c052660e>] acpi_os_execute_notify+0x0/0x2b
 [<c05b03fd>] cpuidle_enable_device+0x31/0x9b
 [<c0545923>] acpi_processor_cst_has_changed+0x40/0x55
 [<c0543ae2>] acpi_processor_notify+0x8b/0xf4
 [<c052bcbb>] acpi_ev_notify_dispatch+0x4c/0x55
 [<c0526630>] acpi_os_execute_notify+0x22/0x2b
 [<c052660e>] acpi_os_execute_notify+0x0/0x2b
 [<c043c212>] run_workqueue+0x7d/0x107
 [<c043fa5b>] prepare_to_wait+0x28/0x45
 [<c043c35a>] worker_thread+0xbe/0xca
 [<c043f8ff>] autoremove_wake_function+0x0/0x35
 [<c043c29c>] worker_thread+0x0/0xca
 [<c043f679>] kthread+0x38/0x5d
 [<c043f641>] kthread+0x0/0x5d
 [<c0406477>] kernel_thread_helper+0x7/0x10
 =======================
Code: c0 89 31 83 c4 14 5b 5e 5f c3 57 b9 04 00 00 00 56 89 c7 53 89 c6 83 ec 04 89 d3 31 c0 f3 ab b8 90 3f 72 c0 89 16 e8 6a cf 16 00 <8b> 53 20 b9 ec 42 4c c0 a1 84 e4 83 c0 89 1c 24 e8 44 6e fd ff 
EIP: [<c04c4716>] sysfs_addrm_start+0x21/0x81 SS:ESP 0068:f78b8ea4
---[ end trace 863306c7f7bb36f7 ]---
Comment 4 Aditya Naga Sanjeevi 2008-04-05 06:01:12 UTC
Oops on 2.6.25-rc8

------------[ cut here ]------------
WARNING: at lib/kref.c:43 kref_get+0x17/0x1c()
Modules linked in: wlan_scan_sta ath_rate_sample ath_pci wlan ath_hal(P) sit tunnel4 ipv6 cbc aes_i586 aes_generic dm_crypt ipt_MASQUERADE iptable_nat nf_nat bridge autofs4 nf_conntrack_ipv4 xt_state nf_conntrack xt_tcpudp ipt_REJECT iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq fuse loop dm_mirror dm_multipath dm_mod snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer sr_mod video 8139cp snd_page_alloc 8139too snd_hwdep i2c_piix4 i2c_core pcspkr output snd battery soundcore ac mii joydev sg cdrom button pata_atiixp pata_acpi sata_sil ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Pid: 70, comm: kacpi_notify Tainted: P         2.6.25-rc8 #2
 [<c0427dcc>] warn_on_slowpath+0x40/0x65
 [<c043007b>] switch_uid+0x5a/0x70
 [<c04147bc>] smp_call_function_single+0x27/0x47
 [<c04f1610>] number+0x120/0x1e6
 [<c04f1ed1>] vsnprintf+0x40a/0x447
 [<c04ef103>] kref_get+0x17/0x1c
 [<c04ee6a0>] kobject_get+0xf/0x13
 [<c04ee72f>] kobject_add_internal+0x42/0x13b
 [<c04ee8dc>] kobject_init_and_add+0x23/0x25
 [<c0596b90>] cpuidle_add_state_sysfs+0x63/0xd7
 [<c05144d4>] acpi_os_execute_deferred+0x0/0x25
 [<c0596498>] cpuidle_enable_device+0x35/0xac
 [<c0531c28>] acpi_processor_cst_has_changed+0x40/0x54
 [<c052fac1>] acpi_processor_notify+0x83/0xde
 [<c0519549>] acpi_ev_notify_dispatch+0x4c/0x57
 [<c05144f1>] acpi_os_execute_deferred+0x1d/0x25
 [<c0435441>] run_workqueue+0x74/0xef
 [<c0435572>] worker_thread+0xb6/0xc2
 [<c0437f8a>] autoremove_wake_function+0x0/0x2d
 [<c04354bc>] worker_thread+0x0/0xc2
 [<c0437d35>] kthread+0x38/0x5d
 [<c0437cfd>] kthread+0x0/0x5d
 [<c0406d47>] kernel_thread_helper+0x7/0x10
 =======================
---[ end trace c2cdf21b5cc60ed6 ]---
BUG: unable to handle kernel NULL pointer dereference at 00000020
IP: [<c04b56d0>] sysfs_addrm_start+0x1e/0x7a
*pde = 5784d067 
Oops: 0000 [#1] SMP 
Modules linked in: wlan_scan_sta ath_rate_sample ath_pci wlan ath_hal(P) sit tunnel4 ipv6 cbc aes_i586 aes_generic dm_crypt ipt_MASQUERADE iptable_nat nf_nat bridge autofs4 nf_conntrack_ipv4 xt_state nf_conntrack xt_tcpudp ipt_REJECT iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq fuse loop dm_mirror dm_multipath dm_mod snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer sr_mod video 8139cp snd_page_alloc 8139too snd_hwdep i2c_piix4 i2c_core pcspkr output snd battery soundcore ac mii joydev sg cdrom button pata_atiixp pata_acpi sata_sil ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]

Pid: 70, comm: kacpi_notify Tainted: P         (2.6.25-rc8 #2)
EIP: 0060:[<c04b56d0>] EFLAGS: 00010246 CPU: 1
EIP is at sysfs_addrm_start+0x1e/0x7a
EAX: 41ed0000 EBX: 00000000 ECX: 00000000 EDX: 00000246
ESI: f7873ee0 EDI: f7873ef0 EBP: 00000000 ESP: f7873ed0
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process kacpi_notify (pid: 70, ti=f7873000 task=f78874d0 task.ti=f7873000)
Stack: f2d86c94 f71484b0 fffffff4 c04b5af4 00000000 00000000 00000000 00000000 
       f2d86c94 fffffffe f2d86c94 f7a9001c c04b5b56 f7873f08 c04ee6a0 f2d86c94 
       c04ee78f f7a90318 f2d86c80 00000000 f2d86c94 f7a9001c c04ee8dc f7873f44 
Call Trace:
 [<c04b5af4>] create_dir+0x33/0x6c
 [<c04b5b56>] sysfs_create_dir+0x29/0x3b
 [<c04ee6a0>] kobject_get+0xf/0x13
 [<c04ee78f>] kobject_add_internal+0xa2/0x13b
 [<c04ee8dc>] kobject_init_and_add+0x23/0x25
 [<c0596b90>] cpuidle_add_state_sysfs+0x63/0xd7
 [<c05144d4>] acpi_os_execute_deferred+0x0/0x25
 [<c0596498>] cpuidle_enable_device+0x35/0xac
 [<c0531c28>] acpi_processor_cst_has_changed+0x40/0x54
 [<c052fac1>] acpi_processor_notify+0x83/0xde
 [<c0519549>] acpi_ev_notify_dispatch+0x4c/0x57
 [<c05144f1>] acpi_os_execute_deferred+0x1d/0x25
 [<c0435441>] run_workqueue+0x74/0xef
 [<c0435572>] worker_thread+0xb6/0xc2
 [<c0437f8a>] autoremove_wake_function+0x0/0x2d
 [<c04354bc>] worker_thread+0x0/0xc2
 [<c0437d35>] kthread+0x38/0x5d
 [<c0437cfd>] kthread+0x0/0x5d
 [<c0406d47>] kernel_thread_helper+0x7/0x10
 =======================
Code: 75 ee 89 56 0c 31 c0 89 31 5b 5e 5f c3 57 b9 04 00 00 00 56 89 c7 53 89 c6 89 d3 31 c0 f3 ab b8 34 83 71 c0 89 16 e8 57 bd 16 00 <8b> 53 20 b9 8c 53 4b c0 a1 88 54 83 c0 53 e8 a6 7f fd ff 5b 85 
EIP: [<c04b56d0>] sysfs_addrm_start+0x1e/0x7a SS:ESP 0068:f7873ed0
---[ end trace c2cdf21b5cc60ed6 ]---
Comment 5 Aditya Naga Sanjeevi 2008-04-05 06:07:32 UTC
Created attachment 15613 [details]
acpidump
Comment 6 Venkatesh Pallipadi 2008-04-05 11:23:08 UTC
Aditya,

Can you please rebuild rc8 kernel, with DEBUG_KOBJECT in your config (Under Kernal Hacking) and reproduce this oops and attach the entire dmesg here.

Thanks.
Comment 7 Aditya Naga Sanjeevi 2008-04-06 04:44:27 UTC
Hello Venki,

I have tried to re compile with the given option. I do not remember if I have
given any other conflicting options, but now, the system is unable to boot with
this kernel. I get:
Kernel Panic: not syncing: smack: Unable to register with kernel.

Let me know if this is anyway related to our problem. I'm trying to re-compile
freshly. I shall update you on the status.

Regards,
Sanjeev
Comment 8 Aditya Naga Sanjeevi 2008-04-06 10:28:42 UTC
Created attachment 15633 [details]
dmesg of 2.6.25-rc8 with kobject-debug
Comment 9 Aditya Naga Sanjeevi 2008-04-06 10:29:45 UTC
Created attachment 15634 [details]
Oops on 2.6.25-rc8 with kobject-debug
Comment 10 Shaohua 2008-04-07 00:45:57 UTC
>d: 70, comm: kacpi_notify Tainted: P 
you have proprietary module loaded, please try to not use it.
Comment 11 Aditya Naga Sanjeevi 2008-04-07 18:36:36 UTC
Created attachment 15663 [details]
modules listing

Attached is the lsmod output on my system.
Let me know which module(s) I need to disable
and test again.

Regards,
Sanjeev
Comment 12 Aditya Naga Sanjeevi 2008-04-13 08:01:17 UTC
I'm eagerly waiting for an update on this! 

Regards,
Sanjeev
Comment 13 Venkatesh Pallipadi 2008-04-21 16:07:19 UTC
ath_hal(P) is the module that seems to be proprietary
Comment 14 Aditya Naga Sanjeevi 2008-04-22 13:35:43 UTC
(In reply to comment #13)
> ath_hal(P) is the module that seems to be proprietary
> 

Hello Venki,

I have just downloaded the latest stable kernel 2.6.25,
and recompiled with earlier options. I haven't used the
propreitery modules. Find attached the bug report. Unfortunately,
its still the same Oops!

------------[ cut here ]------------
WARNING: at lib/kref.c:43 kref_get+0x17/0x1c()
Modules linked in: cbc aes_i586 aes_generic dm_crypt crypto_blkcipher bridge autofs4 ipv6 xt_tcpudp ipt_REJECT iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq fuse loop dm_mirror dm_multipath dm_mod snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_hwdep 8139cp snd 8139too soundcore video output mii pcspkr i2c_piix4 ac battery sr_mod button sg joydev i2c_core cdrom pata_atiixp pata_acpi sata_sil ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Pid: 68, comm: kacpi_notify Not tainted 2.6.25 #3
 [<c04286d4>] warn_on_slowpath+0x40/0x65
 [<c0523376>] acpi_ut_copy_ielement_to_eelement+0x0/0x69
 [<c05233ac>] acpi_ut_copy_ielement_to_eelement+0x36/0x69
 [<c04ece8c>] number+0x120/0x1e6
 [<c04080e8>] do_IRQ+0xa5/0xb9
 [<c04ed74d>] vsnprintf+0x40a/0x447
 [<c04ea993>] kref_get+0x17/0x1c
 [<c04e9e67>] kobject_get+0xf/0x13
 [<c04e9f03>] kobject_add_internal+0x4f/0x17e
 [<c04ea0e6>] kobject_init_and_add+0x23/0x25
 [<c0592d50>] cpuidle_add_state_sysfs+0x63/0xd7
 [<c050f8e5>] acpi_os_execute_deferred+0x0/0x25
 [<c0592658>] cpuidle_enable_device+0x35/0xac
 [<c052d471>] acpi_processor_cst_has_changed+0x40/0x53
 [<c052b298>] acpi_processor_notify+0x83/0xde
 [<c05147f1>] acpi_ev_notify_dispatch+0x4c/0x57
 [<c050f902>] acpi_os_execute_deferred+0x1d/0x25
 [<c0435e31>] run_workqueue+0x74/0xef
 [<c0435f62>] worker_thread+0xb6/0xc2
 [<c0438926>] autoremove_wake_function+0x0/0x2d
 [<c0435eac>] worker_thread+0x0/0xc2
 [<c04386d2>] kthread+0x38/0x5d
 [<c043869a>] kthread+0x0/0x5d
 [<c0406cf7>] kernel_thread_helper+0x7/0x10
 =======================
---[ end trace 7ce68c3dff751460 ]---
kobject: 'state0' (e313e354): kobject_add_internal: parent: '<NULL>', set: '<NULL>'
BUG: unable to handle kernel NULL pointer dereference at 00000020
IP: [<c04b6747>] sysfs_addrm_start+0x1e/0x7a
*pde = 2fe5e067 *pte = 00000000 
Oops: 0000 [#1] SMP 
Modules linked in: cbc aes_i586 aes_generic dm_crypt crypto_blkcipher bridge autofs4 ipv6 xt_tcpudp ipt_REJECT iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq fuse loop dm_mirror dm_multipath dm_mod snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_hwdep 8139cp snd 8139too soundcore video output mii pcspkr i2c_piix4 ac battery sr_mod button sg joydev i2c_core cdrom pata_atiixp pata_acpi sata_sil ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]

Pid: 68, comm: kacpi_notify Not tainted (2.6.25 #3)
EIP: 0060:[<c04b6747>] EFLAGS: 00010246 CPU: 0
EIP is at sysfs_addrm_start+0x1e/0x7a
EAX: 41ed0000 EBX: 00000000 ECX: 00000000 EDX: 00000057
ESI: f783fee0 EDI: f783fef0 EBP: 00000000 ESP: f783fed0
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process kacpi_notify (pid: 68, ti=f783f000 task=f78874d0 task.ti=f783f000)
Stack: e313e354 f17a4c90 fffffff4 c04b6a98 00000000 00000000 00000000 00000000 
       e313e354 fffffffe e313e354 f7aa001c c04b6afa f783ff08 c06316f4 e313e354 
       c04e9f99 f7aa0318 e313e340 00000000 e313e354 f7aa001c c04ea0e6 f783ff44 
Call Trace:
 [<c04b6a98>] create_dir+0x33/0x6c
 [<c04b6afa>] sysfs_create_dir+0x29/0x3b
 [<c04e9f99>] kobject_add_internal+0xe5/0x17e
 [<c04ea0e6>] kobject_init_and_add+0x23/0x25
 [<c0592d50>] cpuidle_add_state_sysfs+0x63/0xd7
 [<c050f8e5>] acpi_os_execute_deferred+0x0/0x25
 [<c0592658>] cpuidle_enable_device+0x35/0xac
 [<c052d471>] acpi_processor_cst_has_changed+0x40/0x53
 [<c052b298>] acpi_processor_notify+0x83/0xde
 [<c05147f1>] acpi_ev_notify_dispatch+0x4c/0x57
 [<c050f902>] acpi_os_execute_deferred+0x1d/0x25
 [<c0435e31>] run_workqueue+0x74/0xef
 [<c0435f62>] worker_thread+0xb6/0xc2
 [<c0438926>] autoremove_wake_function+0x0/0x2d
 [<c0435eac>] worker_thread+0x0/0xc2
 [<c04386d2>] kthread+0x38/0x5d
 [<c043869a>] kthread+0x0/0x5d
 [<c0406cf7>] kernel_thread_helper+0x7/0x10
 =======================
Code: 75 ee 89 56 0c 31 c0 89 31 5b 5e 5f c3 57 b9 04 00 00 00 56 89 c7 53 89 c6 89 d3 31 c0 f3 ab b8 34 13 71 c0 89 16 e8 17 46 16 00 <8b> 53 20 b9 2c 63 4b c0 a1 88 d4 82 c0 53 e8 43 7e fd ff 5b 85 
EIP: [<c04b6747>] sysfs_addrm_start+0x1e/0x7a SS:ESP 0068:f783fed0
---[ end trace 7ce68c3dff751460 ]---
Comment 15 Aditya Naga Sanjeevi 2008-04-22 13:37:03 UTC
Created attachment 15847 [details]
dmesg of 2.6.25
Comment 16 Aditya Naga Sanjeevi 2008-04-22 13:37:57 UTC
Created attachment 15848 [details]
dmesg of 2.6.25 on power disconnection
Comment 17 Aditya Naga Sanjeevi 2008-04-22 13:38:45 UTC
Created attachment 15849 [details]
syslogd on power disconnection
Comment 18 Venkatesh Pallipadi 2008-04-30 13:53:55 UTC
Sorry about the delayed response on this one. I have finally figured out the
reason for this oops. I should have a patch for you to test soon.
Comment 19 Venkatesh Pallipadi 2008-05-01 12:03:16 UTC
Created attachment 16002 [details]
Patch to fix oops AC<->Battery

Sanjeev,

This patch should fix the problem. Can you please test it and Ack.
The patch is against latest git.

Thanks,
Venki
Comment 20 Aditya Naga Sanjeevi 2008-05-02 21:14:48 UTC
Venki,

Sorry for the delay in update. I shall just test it and shall update
you.

Regards,
Sanjeev(In reply to comment #19)
> Created an attachment (id=16002) [details]
> Patch to fix oops AC<->Battery
> 
> Sanjeev,
> 
> This patch should fix the problem. Can you please test it and Ack.
> The patch is against latest git.
> 
> Thanks,
> Venki
> 

Comment 21 Aditya Naga Sanjeevi 2008-05-03 02:44:04 UTC
Hey Venki,

Thats cool! It fixed the problem! Thats great job!
I have tried to boot on battery, boot on power and
disconnect power and both of them worked absolutely
fine. Thank you very much!

On a side note, when disconnecting the power, I hear
the hard disk parking sound (the same as when the 
system shuts down!). Is that okay! But system works
equally fine thereafter.

Kind Regards,
Sanjeev


(In reply to comment #19)
> Created an attachment (id=16002) [details]
> Patch to fix oops AC<->Battery
> 
> Sanjeev,
> 
> This patch should fix the problem. Can you please test it and Ack.
> The patch is against latest git.
> 
> Thanks,
> Venki
> 

Comment 22 Venkatesh Pallipadi 2008-05-05 09:36:23 UTC
Sanjeev - Thanks for testing the patch.

Len - please pickup the patch from comment #19 (with a tested by Sanjeev line added).
Comment 23 voxplus 2008-05-06 20:14:15 UTC
What kernel version include this patch?
Comment 24 Aditya Naga Sanjeevi 2008-05-08 22:17:23 UTC
I Have tested the patch on latest git for 2.6.5 branch.

(In reply to comment #23)
> What kernel version include this patch?
> 

Comment 25 voxplus 2008-05-16 07:56:59 UTC
the kernel version 2.6.25.4 include this patch?
What kernel version include this patch?
Comment 26 Adrian Bunk 2008-06-12 01:31:43 UTC
fix is now as commit dcb84f335bee9c9a7781cfc5d74492dccaf066d2 in Linus' tree (and will therefore be in 2.6.26-rc7 and then in 2.6.26)

Note You need to log in before you can comment on or make changes to this bug.