Bug 10368 - regression breaks lowmem reserved RAM
regression breaks lowmem reserved RAM
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-03-30 11:45 UTC by Rafael J. Wysocki
Modified: 2008-04-02 15:10 UTC (History)
1 user (show)

See Also:
Kernel Version: commit 419c434c35614609fd0c79d335c134bf4b88b30b
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-30 11:45:20 UTC
Subject    : regression breaks lowmem reserved RAM
Submitter  : Andrea Arcangeli <andrea@qumranet.com>
Date       : 2008-03-28 20:49
References : http://lkml.org/lkml/2008/3/28/372

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-30 11:46:37 UTC
Caused by:

commit 419c434c35614609fd0c79d335c134bf4b88b30b
Author: Yang Shi <yang.shi@windriver.com>
Date:   Tue Mar 4 11:20:51 2008 +0100

    Fix DMA access of block device in 64-bit kernel on some non-x86 systems with 4GB or upper 4GB memory
Comment 2 Rafael J. Wysocki 2008-03-30 11:48:58 UTC
commit 419c434c35614609fd0c79d335c134bf4b88b30b

Signed-off-by: Yang Shi <yang.shi@windriver.com>
Signed-off-by: Jens Axboe <jens.axboe@oracle.com>
Comment 3 Rafael J. Wysocki 2008-04-01 17:30:53 UTC
Handled-By : Andrea Arcangeli <andrea@qumranet.com>
Patch : http://lkml.org/lkml/2008/4/1/113

Note You need to log in before you can comment on or make changes to this bug.