Bug 10364 - 2.6.25-rc7: V4L ioctl oops
Summary: 2.6.25-rc7: V4L ioctl oops
Status: CLOSED CODE_FIX
Alias: None
Product: v4l-dvb
Classification: Unclassified
Component: v4l-core (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: v4l-dvb_v4l-core@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-30 11:17 UTC by Rafael J. Wysocki
Modified: 2008-04-02 15:32 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.25-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-30 11:17:22 UTC
Subject    : 2.6.25-rc7: V4L ioctl oops
Submitter  : Meelis Roos <mroos@linux.ee>
Date       : 2008-03-29 12:38
References : http://lkml.org/lkml/2008/3/29/24

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-30 11:18:19 UTC
References : http://lkml.org/lkml/2008/3/27/367
Comment 2 Rafael J. Wysocki 2008-03-30 11:20:01 UTC
References : http://lkml.org/lkml/2008/3/30/71
Comment 3 Rafael J. Wysocki 2008-03-30 11:20:40 UTC
Caused by:

commit 402aa76aa5e57801b4db5ccf8c7beea9f580bb1b
Author: Douglas Schilling Landgraf <dougsland@gmail.com>
Date:   Thu Dec 27 22:20:58 2007 -0300

    V4L/DVB (6911): Converted bttv to use video_ioctl2

    Signed-off-by: Douglas Schilling Landgraf <dougsland@gmail.com>
    Signed-off-by: Mauro Carvalho Chehab <mchehab@infradead.org>
Comment 5 Rafael J. Wysocki 2008-04-02 05:28:46 UTC
Regressions list annotation:
Handled-By : Mauro Carvalho Chehab <mchehab@infradead.org>
Patch : http://lkml.org/lkml/2008/4/1/312
Comment 7 Meelis Roos 2008-04-03 05:24:54 UTC
Commit 49115b7cb1483a14c557666b61fe81d3c23780d6 fixed it for me too, 
thanks!

Note You need to log in before you can comment on or make changes to this bug.