Bug 10363 - ACPI errors / IRQ routing
Summary: ACPI errors / IRQ routing
Status: REJECTED WILL_NOT_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: ykzhao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-30 05:50 UTC by yannis
Modified: 2008-06-18 18:43 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: ---


Attachments
capture (971.03 KB, image/jpeg)
2008-03-30 05:56 UTC, yannis
Details
dmesg acpi off (19.09 KB, application/octet-stream)
2008-03-30 23:45 UTC, yannis
Details
acpidump acpi off (70.03 KB, application/octet-stream)
2008-03-30 23:45 UTC, yannis
Details
lspci acpi off (19.27 KB, application/octet-stream)
2008-03-30 23:46 UTC, yannis
Details
try the debug patch (2.80 KB, patch)
2008-04-10 02:29 UTC, ykzhao
Details | Diff
dmesg with patch (20.20 KB, application/octet-stream)
2008-04-10 17:39 UTC, yannis
Details
dmesg_2.6.25rc8+patch (22.66 KB, application/octet-stream)
2008-04-11 04:23 UTC, yannis
Details
kernel config (83.14 KB, application/octet-stream)
2008-05-22 10:45 UTC, yannis
Details

Description yannis 2008-03-30 05:50:36 UTC
Latest working kernel version: none
Earliest failing kernel version: 2.6.25-rc5-git3
Distribution: all
Hardware Environment: Medion laptop MIM 2080 (MD 95298 black dragon)
Software Environment: 
Problem Description: USB not detected , use noapic works but no irq assigned to the wifi card ! 

Steps to reproduce: use any live cd
Comment 1 yannis 2008-03-30 05:56:05 UTC
Created attachment 15510 [details]
capture

this laptop use a usb CD drive , so it blocks booting of any live cd .
Comment 2 ykzhao 2008-03-30 17:45:38 UTC
Will you please boot the system with "acpi=off" and attach the output of dmesg, acpidump, lspci -vxxx ?
Thanks.
Comment 3 yannis 2008-03-30 23:45:09 UTC
Created attachment 15522 [details]
dmesg acpi off
Comment 4 yannis 2008-03-30 23:45:35 UTC
Created attachment 15523 [details]
acpidump acpi off
Comment 5 yannis 2008-03-30 23:46:01 UTC
Created attachment 15524 [details]
lspci acpi off
Comment 6 Shaohua 2008-04-01 20:13:08 UTC
Interesting, the PCI routing table is quite broken in APIC mode. I'm wondering how windows work. Can you try?
Comment 7 yannis 2008-04-01 23:49:47 UTC
windows XP freeze !
do you think i should reflash the bios (if something is broken ) ?
Comment 8 Shaohua 2008-04-02 01:35:49 UTC
yes, please.
Comment 9 ykzhao 2008-04-03 02:18:02 UTC
Hi, Vannis
    What Shaohua in comment #7 is correct. It seems that the problem is caused by the broken BIOS.
> Device (ALKD)
            {
                Name (_HID, EisaId ("PNP0C0F"))
                Name (_UID, 0x08)
              >  Method (_CRS, 0, NotSerialized)
                {
                    Return (0x00) // Incorrect returned type
                }
            }
    Will you please try to upgrade the BIOS first?
    
    
Comment 10 yannis 2008-04-03 12:30:51 UTC
Hi ,  it's the last bios , 

Shaohua , reflashing don't change any thing ...
Comment 11 yannis 2008-04-09 05:24:53 UTC
hi all !

i modified the dsdt , the resulte is have both usb and wifi working :)
ALKD was the issue , i inspirated from ALKC.

But i still have a bug : cpu frequency can't change anymore :(

Yannis.lg
Comment 12 ykzhao 2008-04-10 02:23:18 UTC
Thanks for the work.
Will you please enable the debug of ACPI and cpufreq in kernel configuration and boot the system with the option of "cpufreq.debug=7 acpi.debug_layer=0x01000000 acpi.debug_level=0x1f" ?
Please attach the output of dmesg. (Of course the modified DSDT is required.)
Thanks.
Comment 13 ykzhao 2008-04-10 02:29:56 UTC
Created attachment 15710 [details]
try the debug patch

Hi, Yannis
    Will you please try the attached debug patch and see whether the system can be booted ?
   If it can be booted, please attach the output of dmesg.

Note: it is unnecessary to use the modified DSDT.
   Thanks.
Comment 14 yannis 2008-04-10 17:39:36 UTC
Created attachment 15731 [details]
dmesg with patch

hi , my custom kernel boot but wifi has no irq ...
regards,
yannis
Comment 15 ykzhao 2008-04-10 21:13:45 UTC
Hi, Yannis
      
    From the log in comment #14 we can know that the system works in PIC mode. And when the sytem is in PIC mode, there is no PCI interrupt routing entry for 00.06.0 device (wireless network) in ACPI PRT table.
    
    It seems that the LOCAL_APIC and IO_APIC is disabled in kernel configuration.
Will you please build the SMP kernel and attach the output as required in comment #12, #13?
Comment 16 yannis 2008-04-11 01:42:07 UTC
Sorry , this was my first kernel compile of my life lol
Now i started a new one with ubuntu config file and kernel 2.6.25 rc8 ...
Comment 17 yannis 2008-04-11 04:23:35 UTC
Created attachment 15732 [details]
dmesg_2.6.25rc8+patch

Great , usb works , wifi works , cpufreq works
Comment 18 yannis 2008-04-12 08:56:14 UTC
Well after some minutes it freeze ...

i don't have this problem with the custom DSDT .
Comment 19 ykzhao 2008-04-13 18:00:12 UTC
Hi, Yannis
    Do you mean that the system will freeze after some minutes when the patch is applied?
    Can you catpure the screenshot when the system freeze?
    Thanks.
Comment 20 Shaohua 2008-04-13 18:25:16 UTC
the freeze might be related with cpuidle, how about deselect cpuidle from kernel config?
Comment 21 yannis 2008-04-14 06:45:38 UTC
it looks better now , can you explain me why ?
Comment 22 yannis 2008-04-17 02:45:19 UTC
i'm still having freezes
Comment 23 ykzhao 2008-04-18 01:48:34 UTC
Will the system still freeze if you unset cpuidle in kernel configuration?
Comment 24 yannis 2008-04-18 13:54:19 UTC
yes
Comment 25 ykzhao 2008-05-06 00:08:24 UTC
Do you mean that the system still freezes after deselecting cpuidle in kernel configuration? It looks inconsistent in comment #21 and #23.
Had better double check the .config file and attach it.

thanks.
Comment 26 yannis 2008-05-22 10:45:24 UTC
Created attachment 16248 [details]
kernel config

Hello,

I retested all again :
-original kernel + original dsdt   : freeze
-custom dsdt : stable
-patch : freeze
-patch + no CPUIDLE : freeze

Please check my config
Comment 27 ykzhao 2008-05-25 20:35:02 UTC
Hi, Yannis
   Thanks for the info.
   From the comment #11 we can know that the incorrect _CRS object of ALKD is modified in the custom DSDT. In fact the workaround patch in comment #13 also fixes the incorrect PCI interrupt routing caused by the incorrect _CRS object and they should have the similiar effect. But the test result is different. 
   >custom dsdt : stable
   > -patch : freeze
   > -patch + no CPUIDLE : freeze
   Will you please confirm whether the same config file is used when using the custom DSDT?
   Will you please give the detailed info where the system freezes? ( Had better capture the screen picture when the system freezes)
   Thanks.
Comment 28 ykzhao 2008-06-18 18:43:11 UTC
Hi, Yannis
    From the acpidump we can know that it is a very clear BIOS bug.
    > Device (ALKD)
            {
                Name (_HID, EisaId ("PNP0C0F"))
                Name (_UID, 0x08)
              >  Method (_CRS, 0, NotSerialized)
                {
                    Return (0x00) // Incorrect returned type
                }
            }
     And windows also freezes on this laptop.  At the same time there is no response for nearly one month, so the bug will be rejected.
   Thanks.

Note You need to log in before you can comment on or make changes to this bug.