Bug 10303 - [BUG] oopses in different processes since 2.6.25-rc5-git4
Summary: [BUG] oopses in different processes since 2.6.25-rc5-git4
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: ReiserFS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ReiseFS developers team
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-21 17:53 UTC by Rafael J. Wysocki
Modified: 2008-03-28 07:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc5-git4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-21 17:53:34 UTC
Subject    : [BUG] oopses in different processes since 2.6.25-rc5-git4
Submitter  : Markus Rehbach <markus.rehbach@gmx.de>
Date       : 2008-03-32 17:18
References : http://lkml.org/lkml/2008/3/21/202

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-21 18:43:10 UTC
Date : 2008-03-21 17:18
(a typo)
Comment 2 Markus Rehbach 2008-03-22 06:58:06 UTC
Rafael,

the oops is gone with -rc6-git6. 

Sigh.....

For completness the link to the original report:
http://article.gmane.org/gmane.linux.kernel/656253

And on Kerneloops:
http://www.kerneloops.org/guilty.php?guilty=__d_lookup&version=2.6.25-rc&start=1638400&end=1671167&class=oops
Comment 3 Rafael J. Wysocki 2008-03-22 10:20:23 UTC
I'll close the bug as unreproducible if it's not present in -rc7.
Comment 4 Markus Rehbach 2008-03-26 00:03:38 UTC
2.6.25-rc5-git3 is oopsing but very seldom. 

Tried 2.6.25-rc6 with another harddisk and fs (xfs instead of reiserfs, debian lenny instead of suse 10.2). The rest of the hardware is the same. This combination of hard-/software works without problems.

-rc7 is out, I will test it with the old harddisk this evening.
Comment 5 Rafael J. Wysocki 2008-03-26 14:51:27 UTC
Confirmation from Christian Kujau <lists@nerdbynature.de>

References : http://www.ussg.iu.edu/hypermail/linux/kernel/0803.3/0789.html
Comment 6 Markus Rehbach 2008-03-27 11:33:14 UTC
Patch exists.

http://lkml.org/lkml/2008/3/27/226

And works for me.
Comment 7 Rafael J. Wysocki 2008-03-27 12:57:53 UTC
Regressions list annotation:
Handled-By : Thomas Gleixner <tglx@linutronix.de>
Patch : http://lkml.org/lkml/2008/3/27/226
Comment 9 Markus Rehbach 2008-03-28 00:28:36 UTC
Linus wasn't really happy with this patch, I assume the following will go into mainline:

http://article.gmane.org/gmane.linux.kernel/658902

Will test and reopen the bug if necessary this evening.
Comment 10 Rafael J. Wysocki 2008-03-28 07:16:15 UTC
Well, this has been merged already too, as

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=3085354de635179d70c240e6d942bcbd1d93056c

I think the bug is fixed for good now.

Note You need to log in before you can comment on or make changes to this bug.