Bug 10302 - 2.6.25-git regression with snd-hda-intel on Dell XPS M1330, no analog sound
Summary: 2.6.25-git regression with snd-hda-intel on Dell XPS M1330, no analog sound
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-21 17:49 UTC by Rafael J. Wysocki
Modified: 2008-09-23 04:13 UTC (History)
4 users (show)

See Also:
Kernel Version: commit 2f32d909f3a85a96074801f6cf20f93324f87646
Tree: Mainline
Regression: Yes


Attachments
Fix wrong master control with STAC codecs (1.08 KB, patch)
2008-04-16 02:49 UTC, Takashi Iwai
Details | Diff

Description Rafael J. Wysocki 2008-03-21 17:49:35 UTC
Subject    : 2.6.25-git regression with snd-hda-intel on Dell XPS M1330, no analog sound
Submitter  : Andre Tomt <andre@tomt.net>
Date       : 2008-03-21 20:03
References : http://lkml.org/lkml/2008/3/21/295
Handled-By : Matthew Ranostay <mranostay@embeddedalley.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-27 14:45:43 UTC
Handled-By : Takashi Iwai <tiwai@suse.de>
Comment 2 Rafael J. Wysocki 2008-03-27 14:46:41 UTC
Takashi, could you please attach the patch fixing the issue or provide a link to it?
Comment 3 Matt Domsch 2008-04-04 05:35:47 UTC
changing Dell address
Comment 4 Takashi Iwai 2008-04-16 02:49:09 UTC
The patch is found in sound-2.6.git tree,
    git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git

Attached below.
Comment 5 Takashi Iwai 2008-04-16 02:49:56 UTC
Created attachment 15766 [details]
Fix wrong master control with STAC codecs
Comment 6 Rafael J. Wysocki 2008-04-16 05:22:17 UTC
Regressions list annotation:
Patch : http://bugzilla.kernel.org/attachment.cgi?id=15766&action=view

Note You need to log in before you can comment on or make changes to this bug.