Bug 10299 - fedora: "linux-2.6-acpi-fix-sizeof.patch" breaks acpi-cpufreq
Summary: fedora: "linux-2.6-acpi-fix-sizeof.patch" breaks acpi-cpufreq
Status: CLOSED DUPLICATE of bug 9558
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Processors (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lin Ming
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-21 09:19 UTC by drago01
Modified: 2008-03-24 21:25 UTC (History)
3 users (show)

See Also:
Kernel Version: kernel-2.6.24.3-47.fc8
Tree: Fedora
Regression: ---


Attachments
dmesg output with cpufreq.debug=7 (28.52 KB, text/plain)
2008-03-21 09:19 UTC, drago01
Details
acpidump output (103.18 KB, text/plain)
2008-03-21 09:19 UTC, drago01
Details
cat /proc/cpuinfo (1.30 KB, text/plain)
2008-03-21 09:20 UTC, drago01
Details
lspci output (28.05 KB, text/plain)
2008-03-21 09:20 UTC, drago01
Details
dmidecode output (9.00 KB, text/plain)
2008-03-21 09:21 UTC, drago01
Details
proposed patch (514 bytes, patch)
2008-03-24 00:26 UTC, Lin Ming
Details | Diff

Description drago01 2008-03-21 09:19:02 UTC
The patch "linux-2.6-acpi-fix-sizeof.patch" breaks acpi-cpufreq on my laptop. It has been backported to fedoras 2.6.24 kernels (now removed again due to this bug). I was asked to report it here. 
See: https://bugzilla.redhat.com/show_bug.cgi?id=436959#c17 (starting from this comment). 
I will attach some debug infos after submitting this.
Comment 1 drago01 2008-03-21 09:19:32 UTC
Created attachment 15377 [details]
dmesg output with cpufreq.debug=7
Comment 2 drago01 2008-03-21 09:19:59 UTC
Created attachment 15378 [details]
acpidump output
Comment 3 drago01 2008-03-21 09:20:23 UTC
Created attachment 15379 [details]
cat /proc/cpuinfo
Comment 4 drago01 2008-03-21 09:20:43 UTC
Created attachment 15380 [details]
lspci output
Comment 5 drago01 2008-03-21 09:21:33 UTC
Created attachment 15381 [details]
dmidecode output
Comment 6 drago01 2008-03-21 09:22:34 UTC
By break acpi-cpufreq I mean it fails to load with "no such device" and the cpu stays at max clock. I hope the infos provided are enough if not feel free to ask for more.
Comment 7 Lin Ming 2008-03-24 00:26:23 UTC
Created attachment 15411 [details]
proposed patch

Please try this patch

Mark buffer data valid when copying external buffer object to internal
Comment 8 drago01 2008-03-24 02:47:34 UTC
(In reply to comment #7)
> Created an attachment (id=15411) [details]
> proposed patch
> 
> Please try this patch
> 
> Mark buffer data valid when copying external buffer object to internal
> 

This one fixes the regression. Thx!
Comment 9 Len Brown 2008-03-24 18:05:18 UTC
what is "linux-2.6-acpi-fix-sizeof.patch"?
Comment 10 Lin Ming 2008-03-24 18:10:54 UTC
Len, 

it's the patch at Bug 9558 #33
http://bugzilla.kernel.org/attachment.cgi?id=14351&action=view
Comment 11 Len Brown 2008-03-24 21:24:35 UTC
The offending patch from bug 9558 was not included upstream.

Unclear why it was included in fedora before it hit
upstream or even the -mm tree, maybe that was a mistake.

So this isn't an upstream regression, but rather it is feedback
on the patch proposed for bug 9558.
Closing as a duplicate of bug 9558.

*** This bug has been marked as a duplicate of bug 9558 ***

Note You need to log in before you can comment on or make changes to this bug.