Bug 10295 - rfkill continous console output
rfkill continous console output
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-03-21 02:01 UTC by Bruce Duncan
Modified: 2008-03-27 18:06 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Bruce Duncan 2008-03-21 02:01:13 UTC
Hey guys,

For as long as I can remember since rt2500pci was my wireless driver, rfkill inserts data once per second into my keyboard stream. Normally, X ignores these data and the problem simply manifests itself as keyboard repetition being stopped once per second.

I think there may have been some change between 2.6.24 and 2.6.25-rc5 which prevents me logging in on a console. Now, during boot, my console is spammed with ^@ (i.e. \0) once per second and I can't log in on the console (because my password is interspersed with ^@!). X still works.

If I remove the rt2500pci and dependant modules, the output stops. If I echo 0 > /sys/class/rfkill/rfkill0/state, the output stops. Otherwise, 0x60 (96) bytes of this output appear every second:

bruce@moon:~$ sudo od -t c -t u1 /dev/input/event5
0000000   >   t 343   G  \0  \0  \0  \0 232  \t  \0  \0  \0  \0  \0  \0
         62 116 227  71   0   0   0   0 154   9   0   0   0   0   0   0
0000020 001  \0 356  \0 001  \0  \0  \0   >   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  62 116 227  71   0   0   0   0
0000040 244  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        164   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0
0000060   ?   t 343   G  \0  \0  \0  \0 236  \t  \0  \0  \0  \0  \0  \0
         63 116 227  71   0   0   0   0 158   9   0   0   0   0   0   0
0000100 001  \0 356  \0 001  \0  \0  \0   ?   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  63 116 227  71   0   0   0   0
0000120 251  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        169   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0
0000140   @   t 343   G  \0  \0  \0  \0 236  \t  \0  \0  \0  \0  \0  \0
         64 116 227  71   0   0   0   0 158   9   0   0   0   0   0   0
0000160 001  \0 356  \0 001  \0  \0  \0   @   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  64 116 227  71   0   0   0   0
0000200 251  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        169   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0
0000220   A   t 343   G  \0  \0  \0  \0 240  \t  \0  \0  \0  \0  \0  \0
         65 116 227  71   0   0   0   0 160   9   0   0   0   0   0   0
0000240 001  \0 356  \0 001  \0  \0  \0   A   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  65 116 227  71   0   0   0   0
0000260 253  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        171   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0
0000300   B   t 343   G  \0  \0  \0  \0 241  \t  \0  \0  \0  \0  \0  \0
         66 116 227  71   0   0   0   0 161   9   0   0   0   0   0   0
0000320 001  \0 356  \0 001  \0  \0  \0   B   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  66 116 227  71   0   0   0   0
0000340 254  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        172   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0
0000360   C   t 343   G  \0  \0  \0  \0 236  \t  \0  \0  \0  \0  \0  \0
         67 116 227  71   0   0   0   0 158   9   0   0   0   0   0   0
0000400 001  \0 356  \0 001  \0  \0  \0   C   t 343   G  \0  \0  \0  \0
          1   0 238   0   1   0   0   0  67 116 227  71   0   0   0   0
0000420 250  \t  \0  \0  \0  \0  \0  \0 001  \0 356  \0  \0  \0  \0  \0
        168   9   0   0   0   0   0   0   1   0 238   0   0   0   0   0

I hope there is enough structure and repetition in this output to allow you to find the source. I didn't bother to bisect to find the cause of the ^@'s on my console, since I don't think it's the underlying problem.

Thanks,
Bruce
Comment 1 Bruce Duncan 2008-03-27 18:06:14 UTC
This problem appears to have been fixed in the latest git (-rc7). Thanks!

Bruce

Note You need to log in before you can comment on or make changes to this bug.