Bug 10272 - acpi_drivers.h: fix dock dummy functions
Summary: acpi_drivers.h: fix dock dummy functions
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Tejun Heo
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-17 13:35 UTC by Adrian Bunk
Modified: 2008-03-18 09:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.25-rc6-git
Tree: Mainline
Regression: Yes


Attachments
patch vs 2.6.25-rc6 (796 bytes, patch)
2008-03-17 21:23 UTC, Len Brown
Details | Diff

Description Adrian Bunk 2008-03-17 13:35:07 UTC
Subject         : acpi_drivers.h: fix dock dummy functions
Submitter       : Thomas Meyer <thomas@m3y3r.de>
References      : http://lkml.org/lkml/2008/3/17/264
Caused-By       : Tejun Heo <htejun@gmail.com>
                  commit 233f112042d0b50170212dbff99c3b34b8773cd3
Handled-By      : Adrian Bunk <adrian.bunk@movial.fi>
Patch           : http://lkml.org/lkml/2008/3/17/296

("Caused-By" refers to the new build error, the bug itself is older)
Comment 1 Len Brown 2008-03-17 21:23:34 UTC
Created attachment 15318 [details]
patch vs 2.6.25-rc6

I like this patch better than Adrian's above
because it makes Tejun's call actually work,
rather than stubbing it out.
Comment 2 Len Brown 2008-03-17 21:25:14 UTC
Looking for an ACK from Tejun and/or Kristen...
Comment 3 Tejun Heo 2008-03-17 22:21:50 UTC
Yes, I like the select one better too.  I'll ack on the mailing list.  Thanks.
Comment 4 Adrian Bunk 2008-03-18 09:21:18 UTC
fixed by commit 0ac4a3c2fbbcadc3e96e4dc47d4ae802d66e6f67

Note You need to log in before you can comment on or make changes to this bug.