Bug 1026 - ACPI and Local APIC don't work together on Presario 2540EA
ACPI and Local APIC don't work together on Presario 2540EA
Status: REJECTED DUPLICATE of bug 1269
Product: ACPI
Classification: Unclassified
Component: BIOS
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-01 07:48 UTC by Gonzalo Fern
Modified: 2004-08-13 19:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0test2
Tree: Mainline
Regression: ---


Attachments
lspci -v of my computer (4.40 KB, text/plain)
2003-08-01 07:51 UTC, Gonzalo Fern
Details
grep -v "^#" of the .config with APIC and ACPI that doesn't boot (5.11 KB, text/plain)
2003-08-01 07:53 UTC, Gonzalo Fern
Details
Dmesg of the above config appendinf acpi=off (11.74 KB, text/plain)
2003-08-01 07:54 UTC, Gonzalo Fern
Details
Config with noapic (4.97 KB, text/plain)
2003-08-01 07:56 UTC, Gonzalo Fern
Details
Dmesg of the config with no apic(607) (10.83 KB, text/plain)
2003-08-01 07:57 UTC, Gonzalo Fern
Details
output of acpidmp (125.67 KB, text/plain)
2003-09-12 15:49 UTC, Gonzalo Fern
Details
Dmesg with linux-2.6-test9 (29.93 KB, text/plain)
2003-11-14 14:57 UTC, Gonzalo Fern
Details
/proc/interrupts of test9 (474 bytes, text/plain)
2003-11-14 14:58 UTC, Gonzalo Fern
Details
/proc/config.gz of test9 (6.06 KB, application/x-gzip-compressed)
2003-11-14 14:59 UTC, Gonzalo Fern
Details
dmidecode (9.23 KB, text/plain)
2003-11-14 15:00 UTC, Gonzalo Fern
Details

Description Gonzalo Fern 2003-08-01 07:48:04 UTC
Distribution: Gentoo
Hardware Environment: Compaq Presario 2540EA (lspci appended)
Software Environment: Gentoo Linux x86
Problem Description: If I boot with APIC and ACPI, computer freezes after
printing ACPI version. If I boot appending acpi=off, the computer boots (dmesg
appended). If I deselect apic, and boot, the computer also boots. 

Steps to reproduce:

.config and dmesg appended
Comment 1 Gonzalo Fern 2003-08-01 07:51:05 UTC
Created attachment 604 [details]
lspci -v of my computer
Comment 2 Gonzalo Fern 2003-08-01 07:53:14 UTC
Created attachment 605 [details]
grep -v "^#" of the .config with APIC and ACPI that doesn't boot
Comment 3 Gonzalo Fern 2003-08-01 07:54:54 UTC
Created attachment 606 [details]
Dmesg of the above config appendinf acpi=off
Comment 4 Gonzalo Fern 2003-08-01 07:56:02 UTC
Created attachment 607 [details]
Config with noapic
Comment 5 Gonzalo Fern 2003-08-01 07:57:35 UTC
Created attachment 608 [details]
Dmesg of the config with no apic(607)
Comment 6 Luming Yu 2003-09-09 00:12:59 UTC
Please attach acpidmp. Thanks a lot!
Comment 7 Gonzalo Fern 2003-09-12 15:49:10 UTC
Created attachment 874 [details]
output of acpidmp
Comment 8 Gonzalo Fern 2003-09-12 15:52:51 UTC
OK. As for linux-2.6.0-test5, I get:

Sep 11 18:53:06 isene kernel: No local APIC present or hardware disabled

with both ACPI and APIC on. So it seems it works for me. 
Comment 9 Len Brown 2003-11-12 20:10:05 UTC
> No local APIC present or hardware disabled 
Can you attach the full dmesg and /proc/interrupts of a recent kernel booted w/ no cmdline flags? 
 
This is behaving as if your system is (now) DMI blacklisted to set "nolapic". 
If you attach the output from dmidecode, that would tell us. 
 
Or perhaps the lapic enable code 
knows something about your system it didn't know in the past. 
Probably if you use cmdline option "lapic", it will over-ride this and 
you can see if the system still fails with the LAPIC enabled. 
 
The dmesg for acpi=off case were full of errors, so it might be that enabling 
the LAPIC on this box is simply a bad idea, and if ACPI is enabled it gets worse. 
 
dmesg with acpi enabled, show an issue too: 
> ACPI: No IRQ known for interrupt pin A of device 0000:00:10.0 
This device is IDE 
> 00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4) (prog-if fa) 
which the AML shows is on LNK5.  But ide0 seems to find itself 
on irq14 correctly anyway.  Unclear why LNK5 fails. 
 
Please verify that you're running the latest BIOS on the system. 
 
Comment 10 Gonzalo Fern 2003-11-14 14:55:50 UTC
>Can you attach the full dmesg and /proc/interrupts of a recent kernel booted 
>w/ no cmdline flags? 
Attached. Also attached config.gz. 

I've discovered a few "sleeping function" in test9 that used not to appear. 
Maybe should I post to LKML?


>If you attach the output from dmidecode, that would tell us. 

Attached, too

>Probably if you use cmdline option "lapic", it will over-ride this and 
>you can see if the system still fails with the LAPIC enabled. 

Yes. With lapic in cmdline, it freezes at boot. Last lines are
ACPI: Subsystem revision 20031002
ACPI:IRQ 9 was Edge TRiggered, setting to Level Triggered
 
 
>dmesg with acpi enabled, show an issue too: 
>> ACPI: No IRQ known for interrupt pin A of device 0000:00:10.0 
>This device is IDE 
>> 00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4) (prog-if fa) 
>which the AML shows is on LNK5.  But ide0 seems to find itself 
>on irq14 correctly anyway.  Unclear why LNK5 fails. 
 
Yes. I saw the message, and I was considering to fill a bug. But as IDE works, 
and google on similar problems doesn't conclude anything, I thought it wasn't 
important. Now I see it is.


>Please verify that you're running the latest BIOS on the system. 

I promise to not buy another Compaq if they fail to provide a BIOS update that 
not requires, not even MS-DOS, but WindowsXP: Updating the BIOS have been a bit 
changelling. BIOS Version is now KH.F.13
 
Comment 11 Gonzalo Fern 2003-11-14 14:57:22 UTC
Created attachment 1446 [details]
Dmesg with linux-2.6-test9
Comment 12 Gonzalo Fern 2003-11-14 14:58:10 UTC
Created attachment 1447 [details]
/proc/interrupts of test9
Comment 13 Gonzalo Fern 2003-11-14 14:59:05 UTC
Created attachment 1448 [details]
/proc/config.gz of test9
Comment 14 Gonzalo Fern 2003-11-14 15:00:49 UTC
Created attachment 1449 [details]
dmidecode

I don't know if it's OK. If you need anything else, please say it.
Comment 15 Gonzalo Fern 2003-11-25 13:34:36 UTC
With linux-2.6-test10, more or less the same problems (no apic or hardware 
disabled and No IRQ known, but not sleeping function).

If you need, just ask.
Comment 16 Len Brown 2003-12-01 00:33:15 UTC
The default for cpu family 15 (P4) changed from enabling lapic by default, 
to requiring the "lapic" command line option: 
 
http://linux.bkbits.net:8080/linux-2.5/diffs/arch/i386/kernel/apic.c@1.47?nav=index.html|src/.|src/arch|src/arch/i386|src/arch/i386/kernel|hist/arch/i386/kernel/apic.c 
 
static int __init detect_init_APIC (void) 
... 
       case X86_VENDOR_INTEL: 
                if (boot_cpu_data.x86 == 6 || 
-                   boot_cpu_data.x86 == 15 || 
+                   (boot_cpu_data.x86 == 15 && (cpu_has_apic || enable_local_apic > 0)) || 
                    (boot_cpu_data.x86 == 5 && cpu_has_apic)) 
                        break; 
                goto no_apic; 
... 
 
So that explains why the change in default behaviour. 
 
This default is independent of ACPI. 
 
So I guess the question is why the LAPIC works with acpi=off, 
but doesn't work with ACPI enabled, yes? 
 
Can you verify that the latest 2.6.0 with "acpi=off" and "lapic" works okay? 
Can you attach the dmesg and /proc/interrupts from that experiment? 
Do ACPI events, such as power button, work in that configuration? 
 
> With lapic in cmdline, it freezes at boot. Last lines are 
> ACPI: Subsystem revision 20031002 
> ACPI:IRQ 9 was Edge TRiggered, setting to Level Triggered 
 
Please apply the following patch to the latest 2.6.0: 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.0-test9/ 
and boot with cmdline options "lapic" and "acpi_pic_sci=edge" to see if perhaps 
we're having trouble because of the ELCR access for IRQ9.  If it works, please 
test ACPI events and attach dmesg and /proc/interrupts. 
If it fails, please report where, and then boot the same kernel with "nolapic" 
and attach the dmesg -- as some of the failures we saw in your -test9 dmesg 
output should be gone now. 
 
Re: IDE interrupt.  I've seen this on several systems, and I'm not worrying about it now 
since in all cases I've seen IDE works. 
 
thanks, 
-Len 
 
Comment 17 Georg Greve 2004-01-22 06:13:22 UTC
Is this identical to 

http://bugzilla.kernel.org/show_bug.cgi?id=1774

?

Both have similar symptoms. 1774 is now resolved, it seems.

Comment 18 Gonzalo Fern 2004-01-23 01:42:34 UTC
Quick test yesterday:

Patch
http://bugzilla.kernel.org/attachment.cgi?id=1927&action=view and lapic in 
cmdline on top of linux 2.6.1 + acpi-20031203-2.6.1.diff.gz boots apparentely 
with APIC.

Notes:

1.-Didn't see /proc/interrupts. Don't know if it's OK
2.-Compiling says something like "Warning: Implicit declaration of function..."
3.-From what I remember, IDE problem seemed to still be present. If it's true 
I'll fill another bug.
4.-Didn't test another problem I had been seeing, while booting with batteries. 
If the problem is still present, I'll fill another bug.

I hope to make confirmation and give details this weekend.

Thanks
Comment 19 Len Brown 2004-01-23 11:29:36 UTC
Thanks Gonzalo for verifying the fix in bug 1269 fixes addresses the problem.
closing as a duplicate.

-Len

*** This bug has been marked as a duplicate of 1269 ***

Note You need to log in before you can comment on or make changes to this bug.