Bug 10235 - 2.6.25-rc5: Blank Screen with Intel 945
2.6.25-rc5: Blank Screen with Intel 945
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: Jesse Barnes
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2008-03-12 16:12 UTC by Rafael J. Wysocki
Modified: 2010-07-24 09:12 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.25-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-12 16:12:08 UTC
Submitter  : Justin Madru <jdm64@gawab.com>
Date       : 2008-03-12 12:02
References : http://lkml.org/lkml/2008/3/12/290
Handled-By : Jesse Barnes <jbarnes@virtuousgeek.org>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-04-07 11:05:00 UTC
References : http://lkml.org/lkml/2008/4/1/318

Jesse said:

Yeah, seems pretty weird.  Given that you see it w/o the fb stuff loaded as 
well and we still have a few open bugs against the intel X driver regarding 
VT switch & mode programming, I don't think this is a real kernel regression.  
It's more likely that some timing or memory layout changed subtly and is 
causing to to hit one of our existing bugs more frequently that you did 
before.  Can you file a bug against the intel X driver at 
bugs.freedesktop.org so we can track it there?  Unless we can find a way to 
reproduce it reliably it'll probably take a long time to fix, but we don't 
want to lose it either...
Comment 2 Rafael J. Wysocki 2008-04-09 12:26:40 UTC
Justin said:

I'm still having the problem even in 2.6.25-rc8. I'm not sure if it's a 
kernel regression or an X.org driver bug.
I think it's at least related to some change from 2.6.24 to 2.6.25 
because I've never had the problem with a 2.6.24 kernel. Although, Jesse 
Barnes thinks it's an intel X.org driver bug.

Whatever the problem it's probably related to one/more of the following:
1) Intel X.org driver bug
2) Intel AGP kernel module
3) Intel DRM i915 kernel module
4) Premptive RCU (it's one of the things that's changed since 2.6.24 - 
along with #5)
5) I/O Port Delay (I've enabled no port delay)

Other than that, I have no idea, except for some strange dependency problem.
Comment 3 Mark Asselstine 2008-06-11 19:44:21 UTC
Definitely exists in 2.6.24 as shipped with Ubuntu. I have a Dell Optiplex 745 which exhibits similar behavior at bootup. Only about 1 in 5 boots will successfully get me to kdm the other 4 result in a hard lockup. Check out bug #220135 on launchpad. I am pretty convinced it is a kernel and intel X.org driver issue.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/220135
Comment 4 Alan 2009-03-23 09:18:58 UTC
Is this still present in 2.6.28 ?
Comment 5 Stefan Pflueger 2009-12-15 11:20:47 UTC
Same issue on my laptop running Debian testing (default 2.6.30-2-686 kernel built by debian).
If any specific information is needed I can try to gather it.
Comment 6 Florian Mickler 2010-04-28 08:16:48 UTC
...ping...

this bug should be closed as it looks like a left-over. 

the mentioned ubuntu bug as well as the corresponding debian and fd.o bugs have been resolved in the meantime, 

also the no-modeset way of doing things is deprecated and not supported anymore by the intel driver developers.

cheers,
Flo
Comment 7 Chris Wilson 2010-07-24 09:12:28 UTC
Timeout -- current bits are believed to be functional on 945, so please double check!

Note You need to log in before you can comment on or make changes to this bug.