Bug 10207 - INFO: task mount:11202 blocked for more than 120 seconds
Summary: INFO: task mount:11202 blocked for more than 120 seconds
Status: CLOSED DUPLICATE of bug 10242
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: LVM2/DM (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alasdair G Kergon
URL:
Keywords:
: 10228 (view as bug list)
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-09 15:26 UTC by Rafael J. Wysocki
Modified: 2008-03-27 15:38 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-09 15:26:07 UTC
Submitter  : Christian Kujau <lists@nerdbynature.de>
Date       : 2008-03-07 21:32
References : http://lkml.org/lkml/2008/3/7/308
Handled-By : David Chinner <dgc@sgi.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-09 15:27:48 UTC
David thinks it may be a dm-crypt bug.

References : http://lkml.org/lkml/2008/3/9/186
Comment 2 Rafael J. Wysocki 2008-03-12 15:24:06 UTC
*** Bug 10228 has been marked as a duplicate of this bug. ***
Comment 3 Herbert Xu 2008-03-14 01:11:59 UTC
Sorry but I'm not the maintainer of dm-crypt.  I think the best person to look into this is Alasdair Kergon.
Comment 4 Milan Broz 2008-03-14 01:40:55 UTC
> Sorry but I'm not the maintainer of dm-crypt.  I think the best person to
> look
> into this is Alasdair Kergon.

yes. (and I will probably handle dm-crypt issues here too)

There is bug in dm-crypt reference count when processing partial write, patch
will follow shortly.
Comment 5 Milan Broz 2008-03-14 02:23:15 UTC
Mentioned patch is here
http://lkml.org/lkml/2008/3/14/71
Comment 6 Rafael J. Wysocki 2008-03-14 04:45:24 UTC
Regressions list annotation:
Patch : http://lkml.org/lkml/2008/3/14/71
Comment 7 Rafael J. Wysocki 2008-03-14 04:46:09 UTC
Handled-By : Milan Broz <mbroz@redhat.com>
Comment 8 Alasdair G Kergon 2008-03-14 09:34:33 UTC
(that patch is not complete BTW - there's a little more to fix that we're working on)
Comment 9 Milan Broz 2008-03-15 07:14:15 UTC
Ref. http://lkml.org/lkml/2008/3/15/38
it seems to be different issue, not related to dm-crypt regression.

For tracking dm-crypt regression we can use bug 10242.
Comment 10 Milan Broz 2008-03-17 12:25:16 UTC
Latest patch for dm-crypt in http://lkml.org/lkml/2008/3/17/214
Comment 11 Rafael J. Wysocki 2008-03-17 13:15:39 UTC
Thanks, but does it fix the $subject problem or the bug #10242, or both?
Comment 12 Rafael J. Wysocki 2008-03-17 14:20:57 UTC
Regressions list annotation:
Patch : http://lkml.org/lkml/2008/3/17/214
Comment 13 Alasdair G Kergon 2008-03-24 05:55:10 UTC
Christian Kujau wrote on the thread that 2.6.25-rc6 with the patch referenced in comment #10 made the hangs go away.  So I think I'll submit this patch.
Comment 14 Rafael J. Wysocki 2008-03-27 15:38:34 UTC

*** This bug has been marked as a duplicate of bug 10242 ***

Note You need to log in before you can comment on or make changes to this bug.