Bug 10204 - WARNING trace for ACPI ECDT
Summary: WARNING trace for ACPI ECDT
Status: CLOSED DUPLICATE of bug 10104
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Tables (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alexey Starikovskiy
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-09 04:35 UTC by Alan Jenkins
Modified: 2008-03-09 15:17 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.25-rc4
Tree: Mainline
Regression: Yes


Attachments
Complete boot log, including WARNING (29.09 KB, text/plain)
2008-03-09 04:36 UTC, Alan Jenkins
Details
Kernel configuration (56.13 KB, text/plain)
2008-03-09 04:37 UTC, Alan Jenkins
Details
acpidump output (91.55 KB, text/plain)
2008-03-09 14:10 UTC, Alan Jenkins
Details

Description Alan Jenkins 2008-03-09 04:35:24 UTC
Latest working kernel version: 2.6.24.3
Earliest failing kernel version: 2.6.25-rc4
Distribution: Ubuntu
Hardware Environment: AMD64
Software Environment: -
Problem Description:

WARNING with backtrace during ACPI initialisation.  Appears to happen while parsing the EC table.

Steps to reproduce:

Boot.  I rebooted again just to be sure, and received the same WARNING.
Comment 1 Alan Jenkins 2008-03-09 04:36:33 UTC
Created attachment 15185 [details]
Complete boot log, including WARNING
Comment 2 Alan Jenkins 2008-03-09 04:37:30 UTC
Created attachment 15186 [details]
Kernel configuration
Comment 3 Alexey Starikovskiy 2008-03-09 14:06:10 UTC
You don't have ECDT, so not parsing of EC table is possible.
Warning happens then we do scan of DSDT for EC device.
Please send output from acpidump.
Comment 4 Alan Jenkins 2008-03-09 14:10:40 UTC
Created attachment 15191 [details]
acpidump output

Here it is
Comment 5 Alexey Starikovskiy 2008-03-09 14:11:57 UTC
Looks like fcea424d31868a78366ad5ee0cb3cc2a4cbe689b is to be blamed.
Comment 6 Alexey Starikovskiy 2008-03-09 14:18:27 UTC
It also looks possible to just drop changes to ioremap.c to return to pre-patch behavior of ACPI/EC.
Comment 7 Rafael J. Wysocki 2008-03-09 15:15:39 UTC
(In reply to comment #5)
> Looks like fcea424d31868a78366ad5ee0cb3cc2a4cbe689b is to be blamed.

commit fcea424d31868a78366ad5ee0cb3cc2a4cbe689b
Author: Arjan van dev Ven <arjan@linux.intel.com>
Date:   Wed Feb 6 05:16:00 2008 +0100

    fix historic ioremap() abuse in AGP

Arjan, Ingo, Andrew, are we going to fix that somehow before 2.6.25?
Comment 8 Rafael J. Wysocki 2008-03-09 15:17:25 UTC

*** This bug has been marked as a duplicate of bug 10104 ***

Note You need to log in before you can comment on or make changes to this bug.