Bug 10173 - Toshiba Bluetooth adapter is disabled - Toshiba Satellite A100-847 (request for omnibook driver)
Toshiba Bluetooth adapter is disabled - Toshiba Satellite A100-847 (request f...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Robert M. Albrecht
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2008-03-05 08:58 UTC by Julian Sikorski
Modified: 2013-04-09 06:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25
Tree: Mainline
Regression: ---


Attachments

Description Julian Sikorski 2008-03-05 08:58:41 UTC
Latest working kernel version: none
Earliest failing kernel version: none
Distribution: Fedora 8
Hardware Environment: Toshiba Satellite A100-847
Software Environment: Fedora 8
Problem Description:
Toshiba Bluetooth adapter is in disabled state by default. It works perfectly well if enabled, which can be accomplished by means of either omnibook module [1]. Merely loading it makes the adapter show up. It can be enabled/disabled as well. Unfortunately, omnibook developers do not have time to merge the driver upstream [2], but maybe it would be possible just to merge some parts of it?

[1] http://omnibook.sourceforge.net/doku.php
[2] http://sourceforge.net/mailarchive/forum.php?thread_name=47234CDE.8080802%40poczta.onet.pl&forum_name=omnibook-devel

Steps to reproduce:
1. Get a Toshiba Satellite A100 laptop (or a similar one)
2. Fire it up
Comment 1 Anonymous Emailer 2008-03-05 10:25:45 UTC
Reply-To: akpm@linux-foundation.org

On Wed,  5 Mar 2008 08:58:42 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10173
> 
>            Summary: Toshiba Bluetooth adapter is disabled
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: 2.6.23.15-137.fc8
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Bluetooth
>         AssignedTo: drivers_bluetooth@kernel-bugs.osdl.org
>         ReportedBy: belegdol@gmail.com
> 
> 
> Latest working kernel version: none
> Earliest failing kernel version: none
> Distribution: Fedora 8
> Hardware Environment: Toshiba Satellite A100-847
> Software Environment: Fedora 8
> Problem Description:
> Toshiba Bluetooth adapter is in disabled state by default. It works perfectly
> well if enabled, which can be accomplished by means of either omnibook module
> [1]. Merely loading it makes the adapter show up. It can be enabled/disabled as
> well. Unfortunately, omnibook developers do not have time to merge the driver
> upstream [2], but maybe it would be possible just to merge some parts of it?
> 
> [1] http://omnibook.sourceforge.net/doku.php
> [2]
> http://sourceforge.net/mailarchive/forum.php?thread_name=47234CDE.8080802%40poczta.onet.pl&forum_name=omnibook-devel
> 
> Steps to reproduce:
> 1. Get a Toshiba Satellite A100 laptop (or a similar one)
> 2. Fire it up
> 

Comment 2 Robert M. Albrecht 2008-04-21 21:45:05 UTC
The same problem applies to all Toshiba notebooks.

There are two families of Toshiba notebooks, the ones made by Compal (Phoenix BIOS), and the original Toshiba manufactured.

The Compal-OEMs are supported by Omnibook (along with some others laptops by HP, ...).

The Toshiba modells need toshiba_acpi. toshiba_acpi is included in the kernel is outdated and does not work on newer modells. The newer one: http://memebeam.org/toys/ExperimentalToshibaAcpiDriver

Both drivers are maintained outside the kernel. Could this change ?
Comment 3 Robert M. Albrecht 2008-04-23 11:39:22 UTC
I think this is more an acpi-problem as a bluetooth-bug, the product should be changed from bluetooth to acpi.
Comment 4 Julian Sikorski 2008-06-13 14:07:07 UTC
For reference, this bug is still present in 2.6.25.6-55.fc9.
Comment 5 Shaohua 2008-11-06 19:09:30 UTC
can you submit the toshiba-acpi patch to acpi maillist, so it can be merged?
Comment 6 Zhang Rui 2008-11-25 23:12:45 UTC
yes, it seems that we need somebody who owns one (at least one) toshiba laptop to volunteer to submit the new toshiba-acpi driver patch and maintain it, better from the omnibook developers.
Comment 7 Robert M. Albrecht 2008-12-15 12:12:48 UTC
Hi,

fixed: http://git.kernel.org/?p=linux/kernel/git/linville/wireless-next-2.6.git;a=commit;h=c41a40c58b623f97dd2e23aa3baab2cedb47d99f

The rfkill-switch does not work. The device is disabled when switched of, but it gets not reenabled.

But the bluetooth dongle is enabled after booting.

cu romal
Comment 8 Julian Sikorski 2008-12-15 12:16:45 UTC
Is this supposed to fix Compal-manufactured Toshibas as well (aka the ones using omnibook module)?
Comment 9 Robert M. Albrecht 2008-12-15 12:22:25 UTC
AFAIK this only works for Toshiba manufactured devices (toshiba_acpi), not for Compal manufactured.

Omnibook module (Compal manufactured) should still be upstreamed. The Compal supporting module omnibook additionaly works on many laptops from HP, ...
Comment 10 Julian Sikorski 2008-12-15 12:31:32 UTC
Well, I opened this bug for my compal-made Satellite A100, so I believe it's not resolved yet. I could open another bug if you wish, though.
When it comes to upstreaming omnibook, it can be a problem. It has not seen a single commit for a really good while, and the code is not good enough to go into the kernel (that's what maintainers said). So, I think the only hope lies in the linux driver project.
Comment 11 Len Brown 2009-01-16 10:09:20 UTC
Hmm, so it looks like resolving the original intent of this bug report
requires getting the omnibook driver upstream.

The driver will need a maintainer, and will need to be submitted for
inclusion upstream, via the staging tree, or otherwise.

When the driver actually exists upstream, then it will make sense
to file bugs against it, but not before. (closing this one)

Note You need to log in before you can comment on or make changes to this bug.