Bug 10168 - WARNING: at drivers/usb/host/ehci-hcd.c:287
Summary: WARNING: at drivers/usb/host/ehci-hcd.c:287
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-04 15:07 UTC by Rafael J. Wysocki
Modified: 2008-03-10 18:57 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.25-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-04 15:07:17 UTC
Subject         : WARNING: at drivers/usb/host/ehci-hcd.c:287
Submitter       : Christian Kujau <lists@nerdbynature.de>
Date            : 2008-03-03 01:05
References      : http://lkml.org/lkml/2008/3/2/171
Handled-By      : Alan Stern <stern@rowland.harvard.edu>
Handled-By      : David Brownell <david-b@pacbell.net>
Patch           : http://lkml.org/lkml/2008/3/4/420

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 David Brownell 2008-03-04 20:21:34 UTC
That WARN_ON should never have been added.  However, see the patch I just attached to Bug #10078.
Comment 2 Adrian Bunk 2008-03-10 18:57:54 UTC
fixed by commit e82cc1288fa57857c6af8c57f3d07096d4bcd9d9

Note You need to log in before you can comment on or make changes to this bug.