Bug 101621 - Thinkpad X60s freezes
Summary: Thinkpad X60s freezes
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-16 16:09 UTC by Robert Alessi
Modified: 2015-10-07 11:18 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.1.2
Tree: Mainline
Regression: Yes


Attachments
dmesg output (133.35 KB, text/plain)
2015-07-16 16:09 UTC, Robert Alessi
Details
system logs (62.00 KB, text/plain)
2015-07-16 16:16 UTC, Robert Alessi
Details
Kernel crash at shutdown (242.55 KB, image/png)
2015-07-24 08:12 UTC, Robert Alessi
Details
dmesg output (133.28 KB, text/plain)
2015-07-25 06:08 UTC, Robert Alessi
Details
system logs (61.93 KB, text/plain)
2015-07-25 06:12 UTC, Robert Alessi
Details

Description Robert Alessi 2015-07-16 16:09:48 UTC
Created attachment 182831 [details]
dmesg output

I noticed that my X60s freezes with linux-libre kernel (Parabola) > 4.0.7.  Up to 4.0.7, everything was fine.

From 4.1.1, I noticed the following:
- during boot process, I have this: "Failed to find cpu0 device mode"
- then after an hour or so, the laptop completely freezes.  I am left with a snapshot of my desktop, and the only thing I can do is press and hold the power button.

This is still present in 4.1.2.

I am not sure that this malfunctioning is related to the graphics.

Please find attached kernel logs at boot (dmesg output).
Comment 1 Robert Alessi 2015-07-16 16:13:33 UTC
I enabled drm.debug=0x06 in GRUB.

Also find attached the system logs at the moment my laptop last froze.
Comment 2 Robert Alessi 2015-07-16 16:16:25 UTC
Created attachment 182851 [details]
system logs
Comment 3 Robert Alessi 2015-07-24 08:12:29 UTC
Created attachment 183591 [details]
Kernel crash at shutdown

The messages I get when kernel crashes at shutdown.  Hope this helps.
Comment 4 Robert Alessi 2015-07-25 06:08:55 UTC
Created attachment 183621 [details]
dmesg output

dmesg output
Comment 5 Robert Alessi 2015-07-25 06:12:34 UTC
Created attachment 183631 [details]
system logs

system logs
Comment 6 zwpwjwtz 2015-08-01 11:45:02 UTC
Also using X60s. Using kernel 4.0.8 and 4.1.2 provided by Fedora.
I found "Failed to find cpu0 device mode" message as well. However the freezing state does not appear.
So I guess it may be due to linux-libre kernel.
Comment 7 Robert Alessi 2015-08-02 07:39:40 UTC
I think that the "Failed to find cpu0 device mode" message is unrelated to this particular issue.  However, I mentioned it here because kernels older than 4.1 (namely 4.0.7) did not display it.

Having said that, I am now running 4.1.3 for almost a week, and my X60s does not freezes any longer.
Comment 8 Robert Alessi 2015-08-02 07:40:15 UTC
"does not freeze". Sorry.
Comment 9 Jani Nikula 2015-10-07 11:18:45 UTC
Thanks for the follow-up. Closing.

Please file any new bug reports at the freedesktop.org bugzilla [1]. Thank you.

[1] https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

Note You need to log in before you can comment on or make changes to this bug.