Bug 10153 - (regression) kernel/timeconst.h bugs with HZ=128
Summary: (regression) kernel/timeconst.h bugs with HZ=128
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM (show other bugs)
Hardware: All Linux
: P1 low
Assignee: David Brownell
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-02 14:57 UTC by Rafael J. Wysocki
Modified: 2009-03-23 09:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc
Tree: Mainline
Regression: Yes


Attachments
[PATCH] Add C99-style constructor macros for specific-sized integers (13.17 KB, patch)
2008-03-02 16:00 UTC, H. Peter Anvin
Details | Diff
[PATCH] Use U64_C() instead of casts in kernel/time.c (1.90 KB, patch)
2008-03-02 16:01 UTC, H. Peter Anvin
Details | Diff

Description Rafael J. Wysocki 2008-03-02 14:57:36 UTC
Subject         : (regression) kernel/timeconst.h bugs with HZ=128
Submitter       : David Brownell <david-b@pacbell.net>
Date            : 2008-02-26 19:32
References      : http://lkml.org/lkml/2008/2/26/294
Handled-By      : "H. Peter Anvin" <hpa@zytor.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 H. Peter Anvin 2008-03-02 15:05:51 UTC
There is no bug here.  The original poster is complaining about gcc issuing a warning, but the code is correct.
Comment 2 David Brownell 2008-03-02 15:36:54 UTC
I'm not sure I understand the rationale for this not being called a "bug" ...

But even if it's "just" a warninng, that's still a regression.  And so it should be fixed.
Comment 3 H. Peter Anvin 2008-03-02 15:53:55 UTC
It's not a bug because the code is correct, both on the source and the binary level.
Comment 4 H. Peter Anvin 2008-03-02 16:00:47 UTC
Created attachment 15114 [details]
[PATCH] Add C99-style constructor macros for specific-sized integers
Comment 5 H. Peter Anvin 2008-03-02 16:01:42 UTC
Created attachment 15115 [details]
[PATCH] Use U64_C() instead of casts in kernel/time.c
Comment 6 Rafael J. Wysocki 2008-03-02 16:21:22 UTC
Regressions list annotation:
Patch : http://bugzilla.kernel.org/attachment.cgi?id=15114&action=view
Patch : http://bugzilla.kernel.org/attachment.cgi?id=15115&action=view

Note You need to log in before you can comment on or make changes to this bug.