Bug 10146 - 2.6.25-rc: complete lockup on boot/start of X (bisected)
Summary: 2.6.25-rc: complete lockup on boot/start of X (bisected)
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-03-02 13:40 UTC by Rafael J. Wysocki
Modified: 2008-03-26 16:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-03-02 13:40:29 UTC
Subject         : 2.6.25-rc: complete lockup on boot/start of X (bisected)
Submitter       : Marcin Slusarz <marcin.slusarz@gmail.com>
Date            : 2008-03-02 20:00
References      : http://lkml.org/lkml/2008/3/2/91
Handled-By      : Peter Zijlstra <a.p.zijlstra@chello.nl>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-03-02 13:42:21 UTC
Caused by:

commit 8f4d37ec073c17e2d4aa8851df5837d798606d6f
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Fri Jan 25 21:08:29 2008 +0100

    sched: high-res preemption tick
Comment 2 Rafael J. Wysocki 2008-03-05 15:47:30 UTC
Is there any progress wrt this regression?
Comment 3 Rafael J. Wysocki 2008-03-23 13:13:31 UTC
Patch : http://lkml.org/lkml/2008/3/23/269
Comment 4 Marcin Slusarz 2008-03-26 16:33:10 UTC
fixed in mainline by 92896bd9fd75b1c993b92874d339a8088bb75560
"Don't 'printk()' while holding xtime lock for writing"

Note You need to log in before you can comment on or make changes to this bug.