Bug 10133 - INFO: possible circular locking in the resume
INFO: possible circular locking in the resume
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Gautham R Shenoy
:
Depends on:
Blocks: 7216 9832
  Show dependency treegraph
 
Reported: 2008-02-29 06:50 UTC by Rafael J. Wysocki
Modified: 2008-04-13 14:40 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc3
Tree: Mainline
Regression: Yes


Attachments
script to offline and online all the cpus on a system (622 bytes, application/octet-stream)
2008-02-29 10:32 UTC, Gautham R Shenoy
Details
script to change the cpufreq governor (289 bytes, application/octet-stream)
2008-02-29 10:32 UTC, Gautham R Shenoy
Details

Description Rafael J. Wysocki 2008-02-29 06:50:48 UTC
Subject         : INFO: possible circular locking in the resume
Submitter       : "Zdenek Kabelac" <zdenek.kabelac@gmail.com>
Date            : 2008-02-27
References      : http://lkml.org/lkml/2008/2/26/479
Handled-By      : Gautham R Shenoy <ego@in.ibm.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Gautham R Shenoy 2008-02-29 10:32:04 UTC
Created attachment 15096 [details]
script to offline and online all the cpus on a system
Comment 2 Gautham R Shenoy 2008-02-29 10:32:25 UTC
Created attachment 15097 [details]
script to change the cpufreq governor
Comment 3 Gautham R Shenoy 2008-02-29 10:33:49 UTC
Easier way to recreate the bug would be to run the above mentioned scripts in parallel.
Comment 4 Rafael J. Wysocki 2008-03-23 14:21:22 UTC
Zdenek, can you please check if the problem is still present/reproducible?
Comment 5 Zdenek Kabelac 2008-03-24 14:47:40 UTC
Well at this moment with current git tree 2.6.25-rc6 actually I've got the problem that after resume my MMC reader doesn't work at all.Yet I've not had time to bisect the kernel for problematic patch - will do in a short time - unless its already known issue?

I'm not sure if this problem is connected to MMC - but I can say but I've not notice this exact backtrace for some time - so maybe it is fixed.
Comment 6 Zdenek Kabelac 2008-04-13 14:17:19 UTC
This warning seems to be fixed - now I could see in the log just these messages:

[42597.114310] wlan0: switched to short barker preamble (BSSID=00:11:d8:da:65:40)
[43222.478903] mmc0: card 5a61 removed
[43552.704815] mmc0: new SD card at address 5a61
[43552.706617] mmcblk0: mmc0:5a61 S016B 14560KiB 
[43552.706841]  mmcblk0: p1
[43224.269009] mmcblk0: error -123 sending read/write command
[43224.269009] end_request: I/O error, dev mmcblk0, sector 0
[43224.269009] Buffer I/O error on device mmcblk0, logical block 0
[43224.269009] mmcblk0: error -123 sending read/write command
[43224.269009] end_request: I/O error, dev mmcblk0, sector 0
[43224.269009] Buffer I/O error on device mmcblk0, logical block 0
[43224.269009] end_request: I/O error, dev mmcblk0, sector 8
[43224.269009] Buffer I/O error on device mmcblk0, logical block 1
[43224.269009] end_request: I/O error, dev mmcblk0, sector 16
[43224.269009] Buffer I/O error on device mmcblk0, logical block 2
[43224.269009] end_request: I/O error, dev mmcblk0, sector 24
[43224.269009] Buffer I/O error on device mmcblk0, logical block 3
[43224.270342] mmcblk0: error -123 sending read/write command
[43224.270381] end_request: I/O error, dev mmcblk0, sector 57
[43224.270384] Buffer I/O error on device mmcblk0p1, logical block 0
...

But reported problem is not reproducible.
Comment 7 Rafael J. Wysocki 2008-04-13 14:40:37 UTC
Closing.  Please reopen if the bug reappears.

Note You need to log in before you can comment on or make changes to this bug.