Bug 10131 - ASUS P5LD2-VM failed to resume if smp enabled
ASUS P5LD2-VM failed to resume if smp enabled
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-02-28 11:28 UTC by Oleksij Rempel (fishor)
Modified: 2008-03-12 06:30 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.21 - 2.6.25-rc2
Tree: Mainline
Regression: ---


Attachments
lspci (6.88 KB, application/octet-stream)
2008-02-28 11:29 UTC, Oleksij Rempel (fishor)
Details
cpuinfo (1.15 KB, application/octet-stream)
2008-02-28 11:29 UTC, Oleksij Rempel (fishor)
Details
dmesg after fresh boot (27.55 KB, application/octet-stream)
2008-02-28 11:30 UTC, Oleksij Rempel (fishor)
Details
acpidump-bin (20.09 KB, application/octet-stream)
2008-02-28 11:34 UTC, Oleksij Rempel (fishor)
Details
dmesg-2.6.21 "working" with oops (95.79 KB, application/octet-stream)
2008-03-04 11:32 UTC, Oleksij Rempel (fishor)
Details
lscpi -vvxxx (25.59 KB, text/plain)
2008-03-09 23:34 UTC, Oleksij Rempel (fishor)
Details
acpidump (93.34 KB, text/plain)
2008-03-09 23:35 UTC, Oleksij Rempel (fishor)
Details
dmesg 2.6.24.3 debug (79.28 KB, text/plain)
2008-03-10 05:07 UTC, Oleksij Rempel (fishor)
Details

Description Oleksij Rempel (fishor) 2008-02-28 11:28:19 UTC
Distribution: ubuntu hardy 8.04
Hardware Environment: ASUS P5LD2-VM ( i945g + ich7 + pentium d 940 )
Software Environment:
Problem Description:
PC can't wakeup if smp is enabled. Workaround is to boot with nosmp.

Suspends seems have a lot of trubles on this PC. I need to use libata.noacpi=1 Bug 9804 and enabled s3_bios and s3_mode quirk for intel grafick.
Comment 1 Oleksij Rempel (fishor) 2008-02-28 11:29:22 UTC
Created attachment 15067 [details]
lspci
Comment 2 Oleksij Rempel (fishor) 2008-02-28 11:29:39 UTC
Created attachment 15068 [details]
cpuinfo
Comment 3 Oleksij Rempel (fishor) 2008-02-28 11:30:12 UTC
Created attachment 15069 [details]
dmesg after fresh boot
Comment 4 Oleksij Rempel (fishor) 2008-02-28 11:34:30 UTC
Created attachment 15070 [details]
acpidump-bin
Comment 5 Andrew Morton 2008-02-28 12:13:08 UTC
Do you know if any earlier kernel versions worked OK?
Comment 6 Oleksij Rempel (fishor) 2008-02-28 12:38:39 UTC
No. This will be alot of work becouse i shortly upgrated my system from nonsmp with celeron d to smp with pentium d

I haw less problem with celeron d or with kernel option nosmp

kernel 2.6.23 olmost working... i mean, it can randomly wake up after short sleep ( like 1 min ) and newer after long one.
here is dmesg with 2.6.23 from Bug 9930
http://bugzilla.kernel.org/attachment.cgi?id=14838&action=view

Comment 7 Zhang Rui 2008-03-02 19:26:51 UTC
(In reply to comment #0)
> PC can't wakeup if smp is enabled. Workaround is to boot with nosmp.
Please boot with nohz=off with/without highres=off and see if it can resume back.


Comment 8 Oleksij Rempel (fishor) 2008-03-03 06:43:34 UTC
Normally display will be disabled after resume, but with options nohz=off and/or highres=off and/orr hpet=disabled and kernel will oops alot. I can't get proper log of oops: 1. after resume ttyS0 do not send any thing ( or becouse i get on client notebook ...irq4 warning ). So i can't debug it with COM. 2. thirst opps is not on the screan, i can't get a picture.

How is about kdump, i newer did it before. Will it work with suspend/resume and should i configure kernel for it with hpet, nohz, loapic enabled like host kernel do?
Comment 9 Oleksij Rempel (fishor) 2008-03-04 02:40:04 UTC
I made some more tests. I have 2GB of RAM, if use only 1GB it working. There is 2 ram blocks each 1GB, they installed to use dualchannel mode but it don't make eny difference. I tested it with memtest and no errors found.

So now, known working konfigurations are: nosmp or mem=1G or unistall one memory block

I tryed agp=off but this oopsed kernel.
Comment 10 Oleksij Rempel (fishor) 2008-03-04 11:27:40 UTC
Latest "working" kernel is 2.6.21. This kernel can resume and go to xorg, but dmesg give:

[  140.432000] kernel BUG at mm/mmap.c:1999!
[  140.432000] invalid opcode: 0000 [#1]
[  140.432000] PREEMPT SMP 
.......
Comment 11 Oleksij Rempel (fishor) 2008-03-04 11:32:21 UTC
Created attachment 15140 [details]
dmesg-2.6.21 "working" with oops
Comment 12 ykzhao 2008-03-09 23:26:42 UTC
Hi, Alexey 
    Will you please attach the output of lspci -vvxxx and acpidump?
    Thanks.
Comment 13 Oleksij Rempel (fishor) 2008-03-09 23:34:35 UTC
Created attachment 15196 [details]
lscpi -vvxxx
Comment 14 Oleksij Rempel (fishor) 2008-03-09 23:35:07 UTC
Created attachment 15197 [details]
acpidump
Comment 15 ykzhao 2008-03-09 23:41:34 UTC
Hi, Alexey 
   Will you please set "CONFIG_PM, CONFIG_PM_TRACE, CONFIG_ACPI_DEBUG" in kernel configuration and do the following test? (Please use the latest kernel, 2.6.24.3)
    a. boot the system with the option of "acpi_sleep=s3_bios libata.noacpi=1 initcall_debug" 
    b. echo 1 > /sys/power/pm_trace 
    c. echo mem > /sys/power/state to enter suspend state
    d. press power button to confirm whether the system can be waked . 
    e. If the system can't be waked, please restart the system 
   
    After test is finished, please attach the output of dmesg.
    Thanks.
   
Comment 16 Oleksij Rempel (fishor) 2008-03-10 05:07:58 UTC
Created attachment 15200 [details]
dmesg 2.6.24.3 debug

Magic number: 0:340:984
Comment 17 Oleksij Rempel (fishor) 2008-03-10 05:11:26 UTC
kernel 2.6.24.4 will cleanly resume after of suspend 2-3 min. After 30 min of suspend it crash on resume.
Comment 18 ykzhao 2008-03-10 18:44:28 UTC
Hi, Alexey
   Thanks for the test. 
   It seems that the system can be waked if only suspend 2-3 mins.
   Will you please do the test as required in comment #15 after the system is suspended for 30 mins?
   
   Thanks.
   
Comment 19 Oleksij Rempel (fishor) 2008-03-11 11:49:26 UTC
Sorry, it seems to be my mistake. I autmaticly used /etc/acpi/susped.sh instead of of echo mem > /sys/power/state. With last one it working perfektly.

some how this script /etc/acpi/susped.sh make kernel oops on SMP system. But, i think, this is other bug.
Comment 20 ykzhao 2008-03-11 23:15:34 UTC
Now the laptop can be resumed from S3 state normally when "echo mem >/sys/power/state" is used.  

The bug will be rejected.

Note You need to log in before you can comment on or make changes to this bug.