Bug 101161 - X-Power module doesn't work on Linx7 Tablet (keeps hanging on refreshing)
Summary: X-Power module doesn't work on Linx7 Tablet (keeps hanging on refreshing)
Status: CLOSED DUPLICATE of bug 88471
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-battery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-07 20:28 UTC by beta992
Modified: 2016-05-16 21:40 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.2RC1
Tree: Mainline
Regression: No


Attachments
Kernel-config (135.59 KB, application/octet-stream)
2015-07-07 20:28 UTC, beta992
Details
Kernel-config, now with the X-Power module (147.10 KB, application/octet-stream)
2015-07-15 18:40 UTC, beta992
Details
acpidump (403.34 KB, application/octet-stream)
2015-08-17 20:32 UTC, beta992
Details
cpuinfo (3.63 KB, text/plain)
2015-08-17 20:32 UTC, beta992
Details
dmesg (46.10 KB, text/plain)
2015-08-17 20:33 UTC, beta992
Details
lspci (543 bytes, text/plain)
2015-08-17 20:33 UTC, beta992
Details

Description beta992 2015-07-07 20:28:19 UTC
Created attachment 182101 [details]
Kernel-config

I'm trying to editing the kernel configuration, to enable X-Powers* support.
Don't know the exact model I need, but therefor want to select multiple models.

Unfortunately I'm unable to locate the devices.
It should be under mdf, but even after trying different kind of configs, it still isn't visible.

Please see my config for details.

Thanks!
Comment 1 beta992 2015-07-15 18:28:45 UTC
Turns out you need to hit the 'Y' key on the I2C section when using menuconfig. :)
Comment 2 beta992 2015-07-15 18:30:43 UTC
Updated status to not working battery indicator.
Comment 3 beta992 2015-07-15 18:40:19 UTC
Created attachment 182741 [details]
Kernel-config, now with the X-Power module
Comment 4 Len Brown 2015-08-11 14:31:55 UTC
Please attach the full output from dmesg
lspci
cat /proc/cpuinfo

and the output from 'acpidump'

to identify the hardware

Looks like you've got CONFIG_AXP288_FUEL_GAUGE=m
already, but unclear if that is sufficient.
Comment 5 beta992 2015-08-17 20:32:40 UTC
Created attachment 185131 [details]
acpidump
Comment 6 beta992 2015-08-17 20:32:56 UTC
Created attachment 185141 [details]
cpuinfo
Comment 7 beta992 2015-08-17 20:33:39 UTC
Created attachment 185151 [details]
dmesg
Comment 8 beta992 2015-08-17 20:33:57 UTC
Created attachment 185161 [details]
lspci
Comment 9 beta992 2015-08-17 20:34:36 UTC
I have added the requested dumps. If you need any more info, please let me know. :)
Comment 10 beta992 2015-08-17 20:42:30 UTC
This is also debug info from upower (in case it is helpful):
● upower.service - Daemon for power management
   Loaded: loaded (/usr/lib/systemd/system/upower.service; enabled; vendor preset: disabled)
   Active: active (running) since ma 2015-08-17 22:37:58 CEST; 2min 8s ago
     Docs: man:upowerd(8)
 Main PID: 1522 (upowerd)
   CGroup: /system.slice/upower.service
           └─1522 /usr/lib/upower/upowerd

aug 17 22:37:58 archtab systemd[1]: Starting Daemon for power management...
aug 17 22:37:58 archtab systemd[1]: Started Daemon for power management.
aug 17 22:37:58 archtab upowerd[1522]: (upowerd:1522): UPower-Linux-WARNING **: no valid voltage value found for device /sys/devices/LNXSYSTM:00/LNXSYBUS:00/80860F41:04/PNP0C0A:01/power_supply/BMBT, assuming 10V
aug 17 22:37:58 archtab upowerd[1522]: (upowerd:1522): UPower-Linux-WARNING **: Setting /sys/devices/LNXSYSTM:00/LNXSYBUS:00/80860F41:04/PNP0C0A:01/power_supply/BMBT state empty as unknown and very low

The battery works OK, and in Windows the status is correctly.
Comment 11 Aaron Lu 2015-08-24 08:08:44 UTC
Battery with XPower PMIC doesn't work right now.

*** This bug has been marked as a duplicate of bug 88471 ***

Note You need to log in before you can comment on or make changes to this bug.